# CVE-2016-1000221: Logstash Logs Sensitive Information

> An attacker with access to Logstash logs can read sensitive HTTP authorization headers due to improper logging practices in the Elasticsearch output plugin.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-vcmm-ppqx-95ch

## What is CVE-2016-1000221?

CVE-2016-1000221 is a high-severity vulnerability in n/a, published on 16 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Logstash prior to version 2.3.4, Elasticsearch Output plugin would log to file HTTP authorization headers which could contain sensitive information.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-1000221?

2 open source packages ship an affected version, including logstash-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `logstash-core` | RubyGems | All versions | 2.3.4 |
| `logstash-core` | RubyGems | All versions | 2.3.4 |

Products: Elastic Logstash.

## How do I fix CVE-2016-1000221?

Upgrade logstash-core to 2.3.4 or later.

## Is CVE-2016-1000221 being exploited?

There is no known exploitation of CVE-2016-1000221 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-7612](https://insights.sbomify.com/CVE-2019-7612/): Information disclosure in Logstash (critical 9.8)
- [CVE-2023-46672](https://insights.sbomify.com/CVE-2023-46672/): Logstash Insertion of Sensitive Information into Log File (high 8.4)
- [CVE-2026-33466](https://insights.sbomify.com/CVE-2026-33466/): Improper Limitation of a Pathname to a Restricted Directory in Logstash Leading to Arbitrary File Write (high 8.1)
- [CVE-2019-7620](https://insights.sbomify.com/CVE-2019-7620/): Denial of service in Logstash (high 7.5)
- [CVE-2015-5378](https://insights.sbomify.com/CVE-2015-5378/): Information disclosure in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-1000221 and fix it if it is affected.

What it is: CVE-2016-1000221 is a high-severity vulnerability in n/a, published on 16 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-1000221 in the wild and no public exploit code.

Affected packages and fixed versions:
- logstash-core (RubyGems): affected all versions; fixed in 2.3.4
- logstash-core (RubyGems): affected all versions; fixed in 2.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-1000221/ (Markdown: https://insights.sbomify.com/CVE-2016-1000221/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-1000221
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-1000221
- OSV: https://osv.dev/vulnerability/CVE-2016-1000221

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-1000221/
Summaries are generated and may contain mistakes; the official description above is the record.
