# CVE-2016-1000229: Improper Neutralization of Input During Web Page Generation in swagger-ui


- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Dec 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-h8wp-wgcq-qhrf

## What is CVE-2016-1000229?

CVE-2016-1000229 is a medium-severity vulnerability in Redhat Openshift, published on 20 Dec 2019. 

### Official description

swagger-ui has XSS in key names

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-1000229?

2 open source packages ship an affected version, including swagger-ui. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swagger-ui` | npm | All versions | 2.2.1 |
| `swagger-ui` | npm | All versions | 2.2.1 |

Products: Redhat Jboss Fuse, Redhat Openshift, Smartbear Swagger-Ui.

## How do I fix CVE-2016-1000229?

Upgrade swagger-ui to 2.2.1 or later.

## Is CVE-2016-1000229 being exploited?

There is no known exploitation of CVE-2016-1000229 in the wild and no public exploit code.

Public exploit code:

- CVE-2016-1000229 (github_poc): https://github.com/barteeees/SwaggerUI-CVE-2016-1000229

## Other vulnerabilities in Redhat Openshift

- [CVE-2020-27782](https://insights.sbomify.com/CVE-2020-27782/): Denial of service in Undertow (high 7.5)
- [CVE-2020-10718](https://insights.sbomify.com/CVE-2020-10718/): Security feature bypass in Wildfly (high 7.5)
- [CVE-2020-1718](https://insights.sbomify.com/CVE-2020-1718/): Improper Authentication for Keycloak (high 7.1)
- [CVE-2014-8175](https://insights.sbomify.com/CVE-2014-8175/): Auth bypass in n/a (medium 6.0)
- [CVE-2020-10734](https://insights.sbomify.com/CVE-2020-10734/): OIDC Logout redirect in keycloak (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-1000229 and fix it if it is affected.

What it is: CVE-2016-1000229 is a medium-severity vulnerability in Redhat Openshift, published on 20 Dec 2019. 
Exploitation: There is no known exploitation of CVE-2016-1000229 in the wild and no public exploit code.

Affected packages and fixed versions:
- swagger-ui (npm): affected all versions; fixed in 2.2.1
- swagger-ui (npm): affected all versions; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-1000229/ (Markdown: https://insights.sbomify.com/CVE-2016-1000229/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-1000229
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-1000229
- OSV: https://osv.dev/vulnerability/CVE-2016-1000229

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-1000229/
Summaries are generated and may contain mistakes; the official description above is the record.
