# CVE-2016-1000237: Cross-Site Scripting in sanitize-html


- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Jan 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-3j7m-hmh3-9jmp, ROOT-APP-NPM-CVE-2016-1000237

## What is CVE-2016-1000237?

CVE-2016-1000237 is a medium-severity vulnerability in n/a, published on 23 Jan 2020. 

### Official description

sanitize-html before 1.4.3 has XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-1000237?

2 open source packages ship an affected version, including sanitize-html. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sanitize-html` | npm | All versions | 1.4.3 |
| `sanitize-html` | npm | All versions | 1.4.3 |

Products: Apostrophecms Sanitize-Html.

## How do I fix CVE-2016-1000237?

Upgrade sanitize-html to 1.4.3 or later.

## Is CVE-2016-1000237 being exploited?

There is no known exploitation of CVE-2016-1000237 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-125128](https://insights.sbomify.com/CVE-2014-125128/): Cross-site scripting in apostrophecms:sanitize-html (medium 6.1)
- [CVE-2019-25225](https://insights.sbomify.com/CVE-2019-25225/): sanitize-html is vulnerable to XSS through incomprehensive sanitization (medium 6.1)
- [CVE-2024-21501](https://insights.sbomify.com/CVE-2024-21501/): sanitize-html Information Exposure vulnerability (medium 5.3)
- [CVE-2022-25887](https://insights.sbomify.com/CVE-2022-25887/): Regular Expression Denial of Service (ReDoS) (medium 5.3)
- [CVE-2021-26539](https://insights.sbomify.com/CVE-2021-26539/): Improper Input Validation in sanitize-html (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-1000237 and fix it if it is affected.

What it is: CVE-2016-1000237 is a medium-severity vulnerability in n/a, published on 23 Jan 2020. 
Exploitation: There is no known exploitation of CVE-2016-1000237 in the wild and no public exploit code.

Affected packages and fixed versions:
- sanitize-html (npm): affected all versions; fixed in 1.4.3
- sanitize-html (npm): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-1000237/ (Markdown: https://insights.sbomify.com/CVE-2016-1000237/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-1000237
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-1000237
- OSV: https://osv.dev/vulnerability/CVE-2016-1000237

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-1000237/
Summaries are generated and may contain mistakes; the official description above is the record.
