CVE-2016-1000282 Critical severity vulnerability that affects Haraka

Critical 9.8 Published Updated

An attacker can execute arbitrary commands on the server via the zip attachment processing plugin in Haraka mail server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-1000282?

CVE-2016-1000282 is a critical command injection vulnerability in n/a, published on 5 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Haraka version 2.8.8 and earlier comes with a plugin for processing attachments for zip files. Versions 2.8.8 and earlier can be vulnerable to command injection.

Weakness: CWE-77

Which versions are affected by CVE-2016-1000282?

2 open source packages ship an affected version, including Haraka. It affects 1 product.

PackageAffectedFixed in
Haraka npmAll versions2.8.9
Haraka npmAll versions2.8.9

Products include Haraka Project Haraka.

How do I fix CVE-2016-1000282?

Upgrade Haraka to 2.8.9 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2016-1000282 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-1000282 exists.

Public exploit code: 1 Metasploit module.

Sources

Also known as GHSA-w5m8-5v9m-xhx5.

Is CVE-2016-1000282 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free