# CVE-2016-1000339: Moderate severity vulnerability that affects org.bouncycastle:bcprov-jdk14 and org.bouncycastle:bcprov-jdk15


- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-1000339, GHSA-c8xf-m4ff-jcxj, UBUNTU-CVE-2016-1000339

## What is CVE-2016-1000339?

CVE-2016-1000339 is a medium-severity vulnerability in Bouncycastle Bc-Java, published on 4 Jun 2018. 

### Official description

In the Bouncy Castle JCE Provider version 1.55 and earlier the primary engine class used for AES was AESFastEngine. Due to the highly table driven approach used in the algorithm it turns out that if the data channel on the CPU can be monitored the lookup table accesses are sufficient to leak information on the AES key being used. There was also a leak in AESEngine although it was substantially less. AESEngine has been modified to remove any signs of leakage (testing carried out on Intel X86-64) and is now the primary AES class for the BC JCE provider from 1.56. Use of AESFastEngine is now only recommended where otherwise deemed appropriate.

Weakness: CWE-310

## Which versions are affected by CVE-2016-1000339?

6 open source packages ship an affected version, including org.bouncycastle:bcprov-jdk14, org.bouncycastle:bcprov-jdk15 and org.bouncycastle:bcprov-jdk15on. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.bouncycastle:bcprov-jdk14` | Maven | All versions | 1.56 |
| `org.bouncycastle:bcprov-jdk14` | Maven | All versions | 1.56 |
| `org.bouncycastle:bcprov-jdk15` | Maven | All versions | 1.56 |
| `org.bouncycastle:bcprov-jdk15` | Maven | All versions | 1.56 |
| `org.bouncycastle:bcprov-jdk15on` | Maven | All versions | 1.56 |
| `org.bouncycastle:bcprov-jdk15on` | Maven | All versions | 1.56 |

Products: Bouncycastle Bc-Java, Debian Debian Linux.

## How do I fix CVE-2016-1000339?

Upgrade org.bouncycastle:bcprov-jdk14 to 1.56 or later.

## Is CVE-2016-1000339 being exploited?

There is no known exploitation of CVE-2016-1000339 in the wild and no public exploit code.

## Other vulnerabilities in Bouncycastle Bc-Java

- [CVE-2007-6721](https://insights.sbomify.com/CVE-2007-6721/): Legion of the Bouncy Castle Java Cryptography API Bleichenbacher Oracle Vulnerability (critical 10.0)
- [CVE-2018-1000613](https://insights.sbomify.com/CVE-2018-1000613/): Deserialization of Untrusted Data in Bouncy castle (critical 9.8)
- [CVE-2026-58062](https://insights.sbomify.com/CVE-2026-58062/): Stapled OCSP response accepted without binding to the checked certificate (critical 9.3)
- [CVE-2026-59638](https://insights.sbomify.com/CVE-2026-59638/): JSSE hostname verifier CN-fallback enabled by default despite documented opt-in (critical 9.3)
- [CVE-2026-59650](https://insights.sbomify.com/CVE-2026-59650/): MTI/A0 DH agreement exponentiates unvalidated peer value (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-1000339 and fix it if it is affected.

What it is: CVE-2016-1000339 is a medium-severity vulnerability in Bouncycastle Bc-Java, published on 4 Jun 2018. 
Exploitation: There is no known exploitation of CVE-2016-1000339 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.bouncycastle:bcprov-jdk14 (Maven): affected all versions; fixed in 1.56
- org.bouncycastle:bcprov-jdk14 (Maven): affected all versions; fixed in 1.56
- org.bouncycastle:bcprov-jdk15 (Maven): affected all versions; fixed in 1.56
- org.bouncycastle:bcprov-jdk15 (Maven): affected all versions; fixed in 1.56
- org.bouncycastle:bcprov-jdk15on (Maven): affected all versions; fixed in 1.56
- org.bouncycastle:bcprov-jdk15on (Maven): affected all versions; fixed in 1.56

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-1000339/ (Markdown: https://insights.sbomify.com/CVE-2016-1000339/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-1000339
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-1000339
- OSV: https://osv.dev/vulnerability/CVE-2016-1000339

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-1000339/
Summaries are generated and may contain mistakes; the official description above is the record.
