# CVE-2016-1000345: Moderate severity vulnerability that affects org.bouncycastle:bcprov-jdk14 and org.bouncycastle:bcprov-jdk15

> Attackers can exploit a padding oracle in Bouncy Castle's DHIES/ECIES CBC mode to decrypt data if timing information is observable.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-1000345, GHSA-9gp4-qrff-c648, UBUNTU-CVE-2016-1000345

## What is CVE-2016-1000345?

CVE-2016-1000345 is a medium-severity vulnerability in Bouncycastle Bc-Java, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In the Bouncy Castle JCE Provider version 1.55 and earlier the DHIES/ECIES CBC mode vulnerable to padding oracle attack. For BC 1.55 and older, in an environment where timings can be easily observed, it is possible with enough observations to identify when the decryption is failing due to padding.

Weakness: CWE-361

## Which versions are affected by CVE-2016-1000345?

6 open source packages ship an affected version, including org.bouncycastle:bcprov-jdk14, org.bouncycastle:bcprov-jdk15 and org.bouncycastle:bcprov-jdk15on. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.bouncycastle:bcprov-jdk14` | Maven | All versions | 1.56 |
| `org.bouncycastle:bcprov-jdk14` | Maven | All versions | 1.56 |
| `org.bouncycastle:bcprov-jdk15` | Maven | All versions | 1.56 |
| `org.bouncycastle:bcprov-jdk15` | Maven | All versions | 1.56 |
| `org.bouncycastle:bcprov-jdk15on` | Maven | All versions | 1.56 |
| `org.bouncycastle:bcprov-jdk15on` | Maven | All versions | 1.56 |

Products: Bouncycastle Bc-Java, Debian Debian Linux.

## How do I fix CVE-2016-1000345?

Upgrade org.bouncycastle:bcprov-jdk14 to 1.56 or later.

## Is CVE-2016-1000345 being exploited?

There is no known exploitation of CVE-2016-1000345 in the wild and no public exploit code.

## Other vulnerabilities in Bouncycastle Bc-Java

- [CVE-2007-6721](https://insights.sbomify.com/CVE-2007-6721/): Legion of the Bouncy Castle Java Cryptography API Bleichenbacher Oracle Vulnerability (critical 10.0)
- [CVE-2018-1000613](https://insights.sbomify.com/CVE-2018-1000613/): Deserialization of Untrusted Data in Bouncy castle (critical 9.8)
- [CVE-2026-58062](https://insights.sbomify.com/CVE-2026-58062/): Stapled OCSP response accepted without binding to the checked certificate (critical 9.3)
- [CVE-2026-59638](https://insights.sbomify.com/CVE-2026-59638/): JSSE hostname verifier CN-fallback enabled by default despite documented opt-in (critical 9.3)
- [CVE-2026-59650](https://insights.sbomify.com/CVE-2026-59650/): MTI/A0 DH agreement exponentiates unvalidated peer value (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-1000345 and fix it if it is affected.

What it is: CVE-2016-1000345 is a medium-severity vulnerability in Bouncycastle Bc-Java, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-1000345 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.bouncycastle:bcprov-jdk14 (Maven): affected all versions; fixed in 1.56
- org.bouncycastle:bcprov-jdk14 (Maven): affected all versions; fixed in 1.56
- org.bouncycastle:bcprov-jdk15 (Maven): affected all versions; fixed in 1.56
- org.bouncycastle:bcprov-jdk15 (Maven): affected all versions; fixed in 1.56
- org.bouncycastle:bcprov-jdk15on (Maven): affected all versions; fixed in 1.56
- org.bouncycastle:bcprov-jdk15on (Maven): affected all versions; fixed in 1.56

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-1000345/ (Markdown: https://insights.sbomify.com/CVE-2016-1000345/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-1000345
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-1000345
- OSV: https://osv.dev/vulnerability/CVE-2016-1000345

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-1000345/
Summaries are generated and may contain mistakes; the official description above is the record.
