# CVE-2016-10006: OWASP AntiSamy vulnerable to Cross-site Scripting

> Attackers can bypass sanitization protections to inject executable code via crafted style tags, leading to cross-site scripting.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Dec 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-10006, GHSA-683w-6h9j-57wq, UBUNTU-CVE-2016-10006

## What is CVE-2016-10006?

CVE-2016-10006 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Dec 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In OWASP AntiSamy before 1.5.5, by submitting a specially crafted input (a tag that supports style with active content), you could bypass the library protections and supply executable code. The impact is XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-10006?

2 open source packages ship an affected version, including org.owasp.antisamy:antisamy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.owasp.antisamy:antisamy` | Maven | All versions | 1.5.5 |
| `org.owasp.antisamy:antisamy` | Maven | All versions | 1.5.5 |

Products: Antisamy Project Antisamy.

## How do I fix CVE-2016-10006?

Upgrade org.owasp.antisamy:antisamy to 1.5.5 or later.

## Is CVE-2016-10006 being exploited?

There is no known exploitation of CVE-2016-10006 in the wild and no public exploit code.

Public exploit code:

- nahsra/antisamy with CVE-2016-10006 (github_poc): https://github.com/epicosy/VUL4J-60
- https://github.com/shoucheng3/nahsra__antisamy_CVE-2016-10006_1-5-3 (github_poc): https://github.com/shoucheng3/nahsra__antisamy_CVE-2016-10006_1-5-3

## Other vulnerabilities in n/a

- [CVE-2022-28366](https://insights.sbomify.com/CVE-2022-28366/): Denial of service in HtmlUnit-Neko (high 7.5)
- [CVE-2024-23635](https://insights.sbomify.com/CVE-2024-23635/): AntiSamy malicious input can provoke XSS when preserving comments (medium 6.1)
- [CVE-2023-43643](https://insights.sbomify.com/CVE-2023-43643/): mXSS in AntiSamy (medium 6.1)
- [CVE-2022-28367](https://insights.sbomify.com/CVE-2022-28367/): Cross-site Scripting in OWASP AntiSamy (medium 6.1)
- [CVE-2022-29577](https://insights.sbomify.com/CVE-2022-29577/): Cross-site Scripting in OWASP AntiSamy (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10006 and fix it if it is affected.

What it is: CVE-2016-10006 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Dec 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-10006 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.5.5
- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10006/ (Markdown: https://insights.sbomify.com/CVE-2016-10006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10006
- OSV: https://osv.dev/vulnerability/CVE-2016-10006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10006/
Summaries are generated and may contain mistakes; the official description above is the record.
