# CVE-2016-10033: PHPMailer Command Injection

> Remote attackers can execute arbitrary code by injecting parameters into the mail command via a crafted Sender property in PHPMailer.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 7 Jul 2025 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Dec 2016
- **Updated:** 21 Oct 2025
- **Also known as:** ALPINE-CVE-2016-10033, CVE-2016-1003, DEBIAN-CVE-2016-10033, DLA-770-1, DSA-3750-1, GHSA-5f37-gxvh-23v6, UBUNTU-CVE-2016-10033

## What is CVE-2016-10033?

CVE-2016-10033 is a critical command injection vulnerability in Joomla Joomla\!, published on 30 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a \" (backslash double quote) in a crafted Sender property.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2016-10033?

2 open source packages ship an affected version, including phpmailer/phpmailer. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmailer/phpmailer` | Packagist | From 5.0.0 | 5.2.18 |
| `phpmailer/phpmailer` | Packagist | From 5.0.0 | 5.2.18 |

Products: Joomla Joomla\!, Phpmailer Project Phpmailer, Wordpress Wordpress.

## How do I fix CVE-2016-10033?

Upgrade phpmailer/phpmailer to 5.2.18 or later. US federal agencies must fix it by 28 Jul 2025.

## Is CVE-2016-10033 being exploited?

Yes. Attackers have exploited CVE-2016-10033 in the wild since at least 7 Jul 2025.

Public exploit code:

- PHPMailer < 5.2.18 Remote Code Execution exploit and vulnerable container (github_poc): https://github.com/opsxcq/exploit-CVE-2016-10033
- RCE against WordPress 4.6; Python port of https://exploitbox.io/vuln/WordPress-Exploit-4-6-RCE-CODE-EXEC-CVE-2016-10033.html (github_poc): https://github.com/GeneralTesler/CVE-2016-10033
- Prevent PHP vulnerabilities similar to CVE-2016-10033 and CVE-2016-10045. (github_poc): https://github.com/Zenexer/safeshell
- PHPMailer < 5.2.18 Remote Code Execution Exploit  (github_poc): https://github.com/0x00-0x00/CVE-2016-10033
- Exploits CVE-2016-10033 and CVE-2016-10045 (github_poc): https://github.com/pedro823/cve-2016-10033-45
- Code and vulnerable WordPress container for exploiting CVE-2016-10033 (github_poc): https://github.com/chipironcin/CVE-2016-10033

## Other vulnerabilities in Joomla Joomla\!

- [CVE-2023-23752](https://insights.sbomify.com/CVE-2023-23752/): Joomla! Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-48902](https://insights.sbomify.com/CVE-2026-48902/): Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links (critical 9.8)
- [CVE-2025-25226](https://insights.sbomify.com/CVE-2025-25226/): [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package (critical 9.8)
- [CVE-2022-23795](https://insights.sbomify.com/CVE-2022-23795/): [20220303] - Core - User row are not bound to a authentication mechanism (critical 9.8)
- [CVE-2022-23797](https://insights.sbomify.com/CVE-2022-23797/): [20220305] - Core - Inadequate filtering on the selected Ids (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10033 and fix it if it is affected.

What it is: CVE-2016-10033 is a critical command injection vulnerability in Joomla Joomla\!, published on 30 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2016-10033 in the wild since at least 7 Jul 2025.

Affected packages and fixed versions:
- phpmailer/phpmailer (Packagist): affected from 5.0.0; fixed in 5.2.18
- phpmailer/phpmailer (Packagist): affected from 5.0.0; fixed in 5.2.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10033/ (Markdown: https://insights.sbomify.com/CVE-2016-10033/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10033
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10033
- OSV: https://osv.dev/vulnerability/CVE-2016-10033

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10033/
Summaries are generated and may contain mistakes; the official description above is the record.
