# CVE-2016-10045: Remote code execution in PHPMailer

> Remote attackers can execute arbitrary code via command injection in PHPMailer's mail transport due to improper escaping.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Dec 2016
- **Updated:** 6 Aug 2024
- **Also known as:** ALPINE-CVE-2016-10045, GHSA-4pc3-96mx-wwc8, UBUNTU-CVE-2016-10045

## What is CVE-2016-10045?

CVE-2016-10045 is a critical command injection vulnerability in Joomla Joomla\!, published on 30 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code by leveraging improper interaction between the escapeshellarg function and internal escaping performed in the mail function in PHP. NOTE: this vulnerability exists because of an incorrect fix for CVE-2016-10033.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2016-10045?

2 open source packages ship an affected version, including phpmailer/phpmailer. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmailer/phpmailer` | Packagist | From 5.0.0 | 5.2.20 |
| `phpmailer/phpmailer` | Packagist | From 5.0.0 | 5.2.20 |

Products: Joomla Joomla\!, Phpmailer Project Phpmailer, Wordpress Wordpress.

## How do I fix CVE-2016-10045?

Upgrade phpmailer/phpmailer to 5.2.20 or later.

## Is CVE-2016-10045 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-10045 exists.

Public exploit code:

- PHPMailer Sendmail Argument Injection (metasploit)
- PHPMailer < 5.2.20 - Remote Code Execution (exploitdb)
- PHPMailer < 5.2.20 / SwiftMailer < 5.4.5-DEV / Zend Framework / zend-mail < 2.4.11 - 'AIO' 'PwnScriptum' Remote Code Execution (exploitdb)
- PHPMailer < 5.2.20 with Exim MTA - Remote Code Execution (exploitdb)

## Other vulnerabilities in Joomla Joomla\!

- [CVE-2016-10033](https://insights.sbomify.com/CVE-2016-10033/): PHPMailer Command Injection (critical 9.8, exploited in the wild)
- [CVE-2023-23752](https://insights.sbomify.com/CVE-2023-23752/): Joomla! Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-48902](https://insights.sbomify.com/CVE-2026-48902/): Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links (critical 9.8)
- [CVE-2025-25226](https://insights.sbomify.com/CVE-2025-25226/): [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package (critical 9.8)
- [CVE-2022-23795](https://insights.sbomify.com/CVE-2022-23795/): [20220303] - Core - User row are not bound to a authentication mechanism (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10045 and fix it if it is affected.

What it is: CVE-2016-10045 is a critical command injection vulnerability in Joomla Joomla\!, published on 30 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-10045 exists.

Affected packages and fixed versions:
- phpmailer/phpmailer (Packagist): affected from 5.0.0; fixed in 5.2.20
- phpmailer/phpmailer (Packagist): affected from 5.0.0; fixed in 5.2.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10045/ (Markdown: https://insights.sbomify.com/CVE-2016-10045/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10045
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10045
- OSV: https://osv.dev/vulnerability/CVE-2016-10045

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10045/
Summaries are generated and may contain mistakes; the official description above is the record.
