# CVE-2016-10074: Swift Mailer mail transport Command Injection

> Remote attackers can execute arbitrary code by injecting commands via crafted email addresses in Swift Mailer headers.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Dec 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-10074, DLA-792-1, DSA-3769-1, GHSA-pr44-4jfr-286m, UBUNTU-CVE-2016-10074

## What is CVE-2016-10074?

CVE-2016-10074 is a critical command injection vulnerability in n/a, published on 30 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The mail transport (aka Swift_Transport_MailTransport) in Swift Mailer before 5.4.5 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a \" (backslash double quote) in a crafted e-mail address in the (1) From, (2) ReturnPath, or (3) Sender header.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2016-10074?

2 open source packages ship an affected version, including swiftmailer/swiftmailer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swiftmailer/swiftmailer` | Packagist | All versions | 5.4.5 |
| `swiftmailer/swiftmailer` | Packagist | All versions | 5.4.5 |

Products: Swiftmailer Swiftmailer.

## How do I fix CVE-2016-10074?

Upgrade swiftmailer/swiftmailer to 5.4.5 or later.

## Is CVE-2016-10074 being exploited?

There is no known exploitation of CVE-2016-10074 in the wild and no public exploit code.

Public exploit code:

- SwiftMailer < 5.4.5-DEV - Remote Code Execution (exploitdb)
- PHPMailer < 5.2.20 / SwiftMailer < 5.4.5-DEV / Zend Framework / zend-mail < 2.4.11 - 'AIO' 'PwnScriptum' Remote Code Execution (exploitdb)
- PHPMailer < 5.2.20 with Exim MTA - Remote Code Execution (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10074 and fix it if it is affected.

What it is: CVE-2016-10074 is a critical command injection vulnerability in n/a, published on 30 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10074 in the wild and no public exploit code.

Affected packages and fixed versions:
- swiftmailer/swiftmailer (Packagist): affected all versions; fixed in 5.4.5
- swiftmailer/swiftmailer (Packagist): affected all versions; fixed in 5.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10074/ (Markdown: https://insights.sbomify.com/CVE-2016-10074/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10074
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10074
- OSV: https://osv.dev/vulnerability/CVE-2016-10074

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10074/
Summaries are generated and may contain mistakes; the official description above is the record.
