# CVE-2016-10075: TDQM Arbitrary Code Execution

> Local attackers can execute arbitrary code by placing a malicious git log in the current working directory when using the tqdm library.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-10075, GHSA-r7q7-xcjw-qx8q, PYSEC-2017-74, openSUSE-SU-2024:11276-1

## What is CVE-2016-10075?

CVE-2016-10075 is a high-severity code injection vulnerability in n/a, published on 19 Jan 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The tqdm._version module in tqdm versions 4.4.1 and 4.10 allows local users to execute arbitrary code via a crafted repo with a malicious git log in the current working directory.

Weakness: CWE-17

## Which versions are affected by CVE-2016-10075?

5 open source packages ship an affected version, including tqdm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tqdm` | PyPI | All versions | 4.11.2 |
| `tqdm` | PyPI | From 4.10.0 | 4.11.2 |
| `tqdm` | PyPI | From 4.10.0 | 4.11.2 |
| `tqdm` | PyPI | From 4.4.1 | 4.11.2 |
| `tqdm` | PyPI | From 4.4.1 | 4.11.2 |

Products: Tqdm Project Tqdm.

## How do I fix CVE-2016-10075?

Upgrade tqdm to 4.11.2 or later.

## Is CVE-2016-10075 being exploited?

There is no known exploitation of CVE-2016-10075 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10075 and fix it if it is affected.

What it is: CVE-2016-10075 is a high-severity code injection vulnerability in n/a, published on 19 Jan 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10075 in the wild and no public exploit code.

Affected packages and fixed versions:
- tqdm (PyPI): affected all versions; fixed in 4.11.2
- tqdm (PyPI): affected from 4.10.0; fixed in 4.11.2
- tqdm (PyPI): affected from 4.10.0; fixed in 4.11.2
- tqdm (PyPI): affected from 4.4.1; fixed in 4.11.2
- tqdm (PyPI): affected from 4.4.1; fixed in 4.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10075/ (Markdown: https://insights.sbomify.com/CVE-2016-10075/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10075
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10075
- OSV: https://osv.dev/vulnerability/CVE-2016-10075

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10075/
Summaries are generated and may contain mistakes; the official description above is the record.
