{"answers":{"affected":"3 open source packages ship an affected version, including pysaml2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10127 in the wild and no public exploit code.","fix":"Upgrade pysaml2 to 4.5.0 or later.","what":"CVE-2016-10127 is a critical vulnerability in n/a, published on 3 Mar 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-10127 and fix it if it is affected.\n\nWhat it is: CVE-2016-10127 is a critical vulnerability in n/a, published on 3 Mar 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-10127 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pysaml2 (PyPI): affected all versions; fixed in 4.5.0\n- pysaml2 (PyPI): affected all versions; fixed in 4.5.0\n- pysaml2 (PyPI): affected all versions; fixed in 4.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10127/ (Markdown: https://insights.sbomify.com/CVE-2016-10127/index.md)","id":"CVE-2016-10127","markdown":"https://insights.sbomify.com/CVE-2016-10127/index.md","name":"CVE-2016-10127","record":{"aliases":["DEBIAN-CVE-2016-10127","GHSA-m269-wj6g-c459","PYSEC-2017-67"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python SAML library","requires_auth":"low_privilege","summary":"Remote attackers can exploit XML external entity vulnerabilities in PySAML2 to read sensitive data or cause denial of service via crafted SAML requests.","user_interaction":"required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"pysaml2","vendor":"pysaml2_project"}],"cvss":{"score":9,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"PySAML2 allows remote attackers to conduct XML external entity (XXE) attacks via a crafted SAML XML request or response.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PySAML2 XML external entity attack","id":"CVE-2016-10127","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xxe","year":"2016"},"n_packages":3,"n_references":6,"next":{"headline":"Memory corruption in n/a","id":"CVE-2016-10128"},"packages":[{"ecosystem":"PyPI","fixed":["4.5.0"],"introduced":["0"],"last_affected":[],"package":"pysaml2","purl":null,"source":"GHSA-m269-wj6g-c459"},{"ecosystem":"PyPI","fixed":["4.5.0"],"introduced":["0"],"last_affected":[],"package":"pysaml2","purl":"pkg:pypi/pysaml2","source":"GHSA-m269-wj6g-c459"},{"ecosystem":"PyPI","fixed":["4.5.0"],"introduced":["0"],"last_affected":[],"package":"pysaml2","purl":"pkg:pypi/pysaml2","source":"PYSEC-2017-67"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2016-10126"},"products":["n/a"],"published":"2017-03-03","related":[{"cvss_score":6.5,"headline":"SAML XML Signature wrapping","id":"CVE-2021-21238","kev_date_added":null,"published":"2021-01-21"},{"cvss_score":5.3,"headline":"Pysaml2 improperly initializes encryption vector","id":"CVE-2017-1000246","kev_date_added":null,"published":"2017-11-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can exploit XML external entity vulnerabilities in PySAML2 to read sensitive data or cause denial of service via crafted SAML requests.","url":"https://insights.sbomify.com/CVE-2016-10127/"}