{"answers":{"affected":"2 open source packages ship an affected version, including bcit-ci/codeigniter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10131 in the wild and no public exploit code.","fix":"Upgrade bcit-ci/codeigniter to 3.1.3 or later.","what":"CVE-2016-10131 is a critical command injection vulnerability in n/a, published on 12 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10131 and fix it if it is affected.\n\nWhat it is: CVE-2016-10131 is a critical command injection vulnerability in n/a, published on 12 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10131 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bcit-ci/codeigniter (Packagist): affected all versions; fixed in 3.1.3\n- bcit-ci/codeigniter (Packagist): affected all versions; fixed in 3.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10131/ (Markdown: https://insights.sbomify.com/CVE-2016-10131/index.md)","id":"CVE-2016-10131","markdown":"https://insights.sbomify.com/CVE-2016-10131/index.md","name":"CVE-2016-10131","record":{"aliases":["GHSA-2pcj-76hj-xqhm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"CodeIgniter framework","requires_auth":"none","summary":"Remote attackers can execute arbitrary code by injecting sendmail arguments via the email from field in CodeIgniter.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"codeigniter","vendor":"codeigniter"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"system/libraries/Email.php in CodeIgniter before 3.1.3 allows remote attackers to execute arbitrary code by leveraging control over the email-\u003efrom field to insert sendmail command-line arguments.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CodeIgniter arbitrary code execution","id":"CVE-2016-10131","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2016"},"n_packages":2,"n_references":4,"next":{"headline":"Null dereference in n/a","id":"CVE-2016-10132"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.3"],"introduced":["0"],"last_affected":[],"package":"bcit-ci/codeigniter","purl":null,"source":"GHSA-2pcj-76hj-xqhm"},{"ecosystem":"Packagist","fixed":["3.1.3"],"introduced":["0"],"last_affected":[],"package":"bcit-ci/codeigniter","purl":"pkg:composer/bcit-ci/codeigniter","source":"GHSA-2pcj-76hj-xqhm"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2016-10130"},"products":["n/a"],"published":"2017-01-12","related":[{"cvss_score":9.8,"headline":"CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability","id":"CVE-2025-54418","kev_date_added":null,"published":"2025-07-28"},{"cvss_score":9.8,"headline":"Remote Code Execution Vulnerability in Validation Placeholders","id":"CVE-2023-32692","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40824","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40825","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40826","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40827","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40828","kev_date_added":null,"published":"2022-10-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code by injecting sendmail arguments via the email from field in CodeIgniter.","url":"https://insights.sbomify.com/CVE-2016-10131/"}