{"answers":{"affected":"4 open source packages ship an affected version, including archive-tar-minitar and minitar. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-10173 in the wild and no public exploit code.","fix":"Upgrade archive-tar-minitar to 0.5.2 or later.","what":"CVE-2016-10173 is a high-severity path traversal vulnerability in n/a, published on 1 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10173 and fix it if it is affected.\n\nWhat it is: CVE-2016-10173 is a high-severity path traversal vulnerability in n/a, published on 1 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10173 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- archive-tar-minitar (RubyGems): affected all versions; fixed in 0.5.2\n- archive-tar-minitar (RubyGems): affected all versions; fixed in 0.5.2\n- minitar (RubyGems): affected all versions; fixed in 0.6\n- minitar (RubyGems): affected all versions; fixed in 0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10173/ (Markdown: https://insights.sbomify.com/CVE-2016-10173/index.md)","id":"CVE-2016-10173","markdown":"https://insights.sbomify.com/CVE-2016-10173/index.md","name":"CVE-2016-10173","record":{"aliases":["DEBIAN-CVE-2016-10173","DLA-808-1","DSA-3778-1","GHSA-h5g2-38x9-4gv3","MGASA-2017-0060","SUSE-SU-2021:0115-1","UBUNTU-CVE-2016-10173","openSUSE-SU-2024:11332-1","openSUSE-SU-2024:11338-1","openSUSE-SU-2024:13163-1","openSUSE-SU-2024:14172-1","openSUSE-SU-2025:15121-1","openSUSE-SU-2026:10354-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby tar library","requires_auth":"none","summary":"Remote attackers can write to arbitrary files via directory traversal in Ruby minitar gems, requiring an upgrade to secure the application.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"archive-tar-minitar","vendor":"minitar"},{"product":"minitar","vendor":"minitar"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory traversal vulnerability in the minitar before 0.6 and archive-tar-minitar 0.5.2 gems for Ruby allows remote attackers to write to arbitrary files via a .. (dot dot) in a TAR archive entry.","ecosystems":["RubyGems","SUSE:Linux Enterprise Module for Containers 12","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"archive-tar-minitar and minitar vulnerable to Path Traversal","id":"CVE-2016-10173","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"path_traversal","year":"2016"},"n_packages":9,"n_references":8,"next":{"headline":"NETGEAR WNR2000v5 Router Buffer Overflow","id":"CVE-2016-10174"},"packages":[{"ecosystem":"RubyGems","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"archive-tar-minitar","purl":null,"source":"GHSA-h5g2-38x9-4gv3"},{"ecosystem":"RubyGems","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"archive-tar-minitar","purl":"pkg:gem/archive-tar-minitar","source":"GHSA-h5g2-38x9-4gv3"},{"ecosystem":"RubyGems","fixed":["0.6"],"introduced":["0"],"last_affected":[],"package":"minitar","purl":null,"source":"GHSA-h5g2-38x9-4gv3"},{"ecosystem":"RubyGems","fixed":["0.6"],"introduced":["0"],"last_affected":[],"package":"minitar","purl":"pkg:gem/minitar","source":"GHSA-h5g2-38x9-4gv3"},{"ecosystem":"SUSE:Linux Enterprise Module for Containers 12","fixed":["0.5.2-7.3.65"],"introduced":["0"],"last_affected":[],"package":"rubygem-archive-tar-minitar","purl":"pkg:rpm/suse/rubygem-archive-tar-minitar\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Containers%2012","source":"SUSE-SU-2021:0115-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.9-1.13"],"introduced":["0"],"last_affected":[],"package":"ruby3.2-rubygem-minitar","purl":"pkg:rpm/opensuse/ruby3.2-rubygem-minitar\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13163-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.9-1.17"],"introduced":["0"],"last_affected":[],"package":"rubygem-minitar","purl":"pkg:rpm/opensuse/rubygem-minitar\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14172-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.9-1.19"],"introduced":["0"],"last_affected":[],"package":"rubygem-minitar","purl":"pkg:rpm/opensuse/rubygem-minitar\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15121-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.9-1.21"],"introduced":["0"],"last_affected":[],"package":"rubygem-minitar","purl":"pkg:rpm/opensuse/rubygem-minitar\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10354-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2016-10172"},"products":["n/a"],"published":"2017-02-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can write to arbitrary files via directory traversal in Ruby minitar gems, requiring an upgrade to secure the application.","url":"https://insights.sbomify.com/CVE-2016-10173/"}