# CVE-2016-10173: archive-tar-minitar and minitar vulnerable to Path Traversal

> Remote attackers can write to arbitrary files via directory traversal in Ruby minitar gems, requiring an upgrade to secure the application.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-10173, DLA-808-1, DSA-3778-1, GHSA-h5g2-38x9-4gv3, MGASA-2017-0060, SUSE-SU-2021:0115-1, UBUNTU-CVE-2016-10173, openSUSE-SU-2024:11332-1, openSUSE-SU-2024:11338-1, openSUSE-SU-2024:13163-1, openSUSE-SU-2024:14172-1, openSUSE-SU-2025:15121-1, openSUSE-SU-2026:10354-1

## What is CVE-2016-10173?

CVE-2016-10173 is a high-severity path traversal vulnerability in n/a, published on 1 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in the minitar before 0.6 and archive-tar-minitar 0.5.2 gems for Ruby allows remote attackers to write to arbitrary files via a .. (dot dot) in a TAR archive entry.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2016-10173?

4 open source packages ship an affected version, including archive-tar-minitar and minitar. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `archive-tar-minitar` | RubyGems | All versions | 0.5.2 |
| `archive-tar-minitar` | RubyGems | All versions | 0.5.2 |
| `minitar` | RubyGems | All versions | 0.6 |
| `minitar` | RubyGems | All versions | 0.6 |
| `rubygem-archive-tar-minitar` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 0.5.2-7.3.65 |
| `ruby3.2-rubygem-minitar` | openSUSE:Tumbleweed | All versions | 0.9-1.13 |
| `rubygem-minitar` | openSUSE:Tumbleweed | All versions | 0.9-1.17 |
| `rubygem-minitar` | openSUSE:Tumbleweed | All versions | 0.9-1.19 |
| `rubygem-minitar` | openSUSE:Tumbleweed | All versions | 0.9-1.21 |

Products: Minitar Archive-Tar-Minitar, Minitar Minitar.

## How do I fix CVE-2016-10173?

Upgrade archive-tar-minitar to 0.5.2 or later.

## Is CVE-2016-10173 being exploited?

There is no known exploitation of CVE-2016-10173 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10173 and fix it if it is affected.

What it is: CVE-2016-10173 is a high-severity path traversal vulnerability in n/a, published on 1 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10173 in the wild and no public exploit code.

Affected packages and fixed versions:
- archive-tar-minitar (RubyGems): affected all versions; fixed in 0.5.2
- archive-tar-minitar (RubyGems): affected all versions; fixed in 0.5.2
- minitar (RubyGems): affected all versions; fixed in 0.6
- minitar (RubyGems): affected all versions; fixed in 0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10173/ (Markdown: https://insights.sbomify.com/CVE-2016-10173/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10173
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10173
- OSV: https://osv.dev/vulnerability/CVE-2016-10173

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10173/
Summaries are generated and may contain mistakes; the official description above is the record.
