# CVE-2016-10193: espeak-ruby allows arbitrary command execution

> Remote attackers can execute arbitrary commands via shell metacharacters in input strings passed to the espeak-ruby gem methods.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-4jm3-pfpf-h54p

## What is CVE-2016-10193?

CVE-2016-10193 is a critical command injection vulnerability in n/a, published on 3 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The espeak-ruby gem before 1.0.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a string to the speak, save, bytes or bytes_wav method in lib/espeak/speech.rb.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2016-10193?

2 open source packages ship an affected version, including espeak-ruby. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `espeak-ruby` | RubyGems | All versions | 1.0.3 |
| `espeak-ruby` | RubyGems | All versions | 1.0.3 |

Products: Espeak-Ruby Project Espeak-Ruby.

## How do I fix CVE-2016-10193?

Upgrade espeak-ruby to 1.0.3 or later.

## Is CVE-2016-10193 being exploited?

There is no known exploitation of CVE-2016-10193 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10193 and fix it if it is affected.

What it is: CVE-2016-10193 is a critical command injection vulnerability in n/a, published on 3 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10193 in the wild and no public exploit code.

Affected packages and fixed versions:
- espeak-ruby (RubyGems): affected all versions; fixed in 1.0.3
- espeak-ruby (RubyGems): affected all versions; fixed in 1.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10193/ (Markdown: https://insights.sbomify.com/CVE-2016-10193/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10193
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10193
- OSV: https://osv.dev/vulnerability/CVE-2016-10193

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10193/
Summaries are generated and may contain mistakes; the official description above is the record.
