# CVE-2016-10345: Phusion Passenger uses a known /tmp filename

> Local attackers can exploit a predictable temporary file path during module installation to gain the privileges of the Passenger user.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2017
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2016-10345, GHSA-cqxw-3p7v-p9gr, SUSE-SU-2017:1316-1, UBUNTU-CVE-2016-10345

## What is CVE-2016-10345?

CVE-2016-10345 is a high-severity path traversal vulnerability in n/a, published on 18 Apr 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Phusion Passenger before 5.1.0, a known /tmp filename was used during passenger-install-nginx-module execution, which could allow local attackers to gain the privileges of the passenger user.

Weakness: CWE-264

## Which versions are affected by CVE-2016-10345?

2 open source packages ship an affected version, including passenger. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passenger` | RubyGems | All versions | 5.1.0 |
| `passenger` | RubyGems | All versions | 5.1.0 |
| `rubygem-passenger` | SUSE:Lifecycle Management Server 1.3 | All versions | 3.0.14-0.17.1 |
| `rubygem-passenger` | SUSE:Studio Onsite 1.3 | All versions | 3.0.14-0.17.1 |
| `rubygem-passenger` | SUSE:WebYast 1.3 | All versions | 3.0.14-0.17.1 |

Products: Phusion Passenger.

## How do I fix CVE-2016-10345?

Upgrade passenger to 5.1.0 or later.

## Is CVE-2016-10345 being exploited?

There is no known exploitation of CVE-2016-10345 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-12026](https://insights.sbomify.com/CVE-2018-12026/): Phusion Passenger SpawningKit Contains Arbitrary Read/Write Vulnerability (critical 9.8)
- [CVE-2018-12027](https://insights.sbomify.com/CVE-2018-12027/): Insecure Permissions in Phusion Passenger (high 8.8)
- [CVE-2018-12028](https://insights.sbomify.com/CVE-2018-12028/): Incorrect Access Control in Phusion Passenger (high 7.8)
- [CVE-2012-6135](https://insights.sbomify.com/CVE-2012-6135/): RubyGems passenger gem allows remote attackers to delete files (high 7.5)
- [CVE-2025-26803](https://insights.sbomify.com/CVE-2025-26803/): Phusion Passenger denial of service (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10345 and fix it if it is affected.

What it is: CVE-2016-10345 is a high-severity path traversal vulnerability in n/a, published on 18 Apr 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10345 in the wild and no public exploit code.

Affected packages and fixed versions:
- passenger (RubyGems): affected all versions; fixed in 5.1.0
- passenger (RubyGems): affected all versions; fixed in 5.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10345/ (Markdown: https://insights.sbomify.com/CVE-2016-10345/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10345
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10345
- OSV: https://osv.dev/vulnerability/CVE-2016-10345

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10345/
Summaries are generated and may contain mistakes; the official description above is the record.
