{"answers":{"affected":"2 open source packages ship an affected version, including logstash-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10362 in the wild and no public exploit code.","fix":"Upgrade logstash-core to 5.0.1 or later.","what":"CVE-2016-10362 is a medium-severity vulnerability in Elastic Logstash, published on 16 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10362 and fix it if it is affected.\n\nWhat it is: CVE-2016-10362 is a medium-severity vulnerability in Elastic Logstash, published on 16 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10362 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- logstash-core (RubyGems): affected all versions; fixed in 5.0.1\n- logstash-core (RubyGems): affected all versions; fixed in 5.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10362/ (Markdown: https://insights.sbomify.com/CVE-2016-10362/index.md)","id":"CVE-2016-10362","markdown":"https://insights.sbomify.com/CVE-2016-10362/index.md","name":"CVE-2016-10362","record":{"aliases":["GHSA-3gg4-6hqg-2vjx"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Logstash Elasticsearch plugin","requires_auth":"low_privilege","summary":"An attacker with access to Logstash logs can read exposed HTTP basic auth credentials for Elasticsearch connections.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"elastic","cpe":[{"product":"output_plugin","vendor":"elasticsearch"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"},{"id":"CWE-532","name":"Insertion of Sensitive Information into Log File"}],"description":"Prior to Logstash version 5.0.1, Elasticsearch Output plugin when updating connections after sniffing, would log to file HTTP basic auth credentials.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Logstash Logs Sensitive Information","id":"CVE-2016-10362","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2016"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of service in Logstash","id":"CVE-2016-10363"},"packages":[{"ecosystem":"RubyGems","fixed":["5.0.1"],"introduced":["0"],"last_affected":[],"package":"logstash-core","purl":null,"source":"GHSA-3gg4-6hqg-2vjx"},{"ecosystem":"RubyGems","fixed":["5.0.1"],"introduced":["0"],"last_affected":[],"package":"logstash-core","purl":"pkg:gem/logstash-core","source":"GHSA-3gg4-6hqg-2vjx"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2016-10361"},"products":["Logstash"],"published":"2017-06-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["Elastic"]},"summary":"An attacker with access to Logstash logs can read exposed HTTP basic auth credentials for Elasticsearch connections.","url":"https://insights.sbomify.com/CVE-2016-10362/"}