# CVE-2016-10362: Logstash Logs Sensitive Information

> An attacker with access to Logstash logs can read exposed HTTP basic auth credentials for Elasticsearch connections.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-3gg4-6hqg-2vjx

## What is CVE-2016-10362?

CVE-2016-10362 is a medium-severity vulnerability in Elastic Logstash, published on 16 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Prior to Logstash version 5.0.1, Elasticsearch Output plugin when updating connections after sniffing, would log to file HTTP basic auth credentials.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2016-10362?

2 open source packages ship an affected version, including logstash-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `logstash-core` | RubyGems | All versions | 5.0.1 |
| `logstash-core` | RubyGems | All versions | 5.0.1 |

Products: Elasticsearch Output Plugin.

## How do I fix CVE-2016-10362?

Upgrade logstash-core to 5.0.1 or later.

## Is CVE-2016-10362 being exploited?

There is no known exploitation of CVE-2016-10362 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10362 and fix it if it is affected.

What it is: CVE-2016-10362 is a medium-severity vulnerability in Elastic Logstash, published on 16 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10362 in the wild and no public exploit code.

Affected packages and fixed versions:
- logstash-core (RubyGems): affected all versions; fixed in 5.0.1
- logstash-core (RubyGems): affected all versions; fixed in 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10362/ (Markdown: https://insights.sbomify.com/CVE-2016-10362/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10362
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10362
- OSV: https://osv.dev/vulnerability/CVE-2016-10362

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10362/
Summaries are generated and may contain mistakes; the official description above is the record.
