{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10376 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2016-10376 is a medium-severity vulnerability in n/a, published on 28 May 2017. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-10376 and fix it if it is affected.\n\nWhat it is: CVE-2016-10376 is a medium-severity vulnerability in n/a, published on 28 May 2017. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-10376 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10376/ (Markdown: https://insights.sbomify.com/CVE-2016-10376/index.md)","id":"CVE-2016-10376","markdown":"https://insights.sbomify.com/CVE-2016-10376/index.md","name":"CVE-2016-10376","record":{"aliases":["DEBIAN-CVE-2016-10376","DLA-967-1","DSA-3943-1","GHSA-5wv2-923f-jxwr","MGASA-2017-0166","UBUNTU-CVE-2016-10376","openSUSE-SU-2024:10775-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"XMPP client","requires_auth":"high_privilege","summary":"Malicious XMPP servers can extract plaintext from OTR encrypted sessions in Gajim due to unconditional implementation of remote control extensions.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"gajim","vendor":"gajim"}],"cvss":{"score":4.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-310","name":null}],"description":"Gajim through 0.16.7 unconditionally implements the \"XEP-0146: Remote Controlling Clients\" extension. This can be abused by malicious XMPP servers to, for example, extract plaintext from OTR encrypted sessions.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in n/a","id":"CVE-2016-10376","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2016"},"n_packages":1,"n_references":6,"next":{"headline":"Integer overflow in n/a","id":"CVE-2016-10377"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.3.2-1.2"],"introduced":["0"],"last_affected":[],"package":"gajim","purl":"pkg:rpm/opensuse/gajim\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10775-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2016-10375"},"products":["n/a"],"published":"2017-05-28","related":[{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2021-41055","kev_date_added":null,"published":"2021-10-11"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2012-2086","kev_date_added":null,"published":"2012-11-23"},{"cvss_score":6.8,"headline":"Command injection in n/a","id":"CVE-2012-2085","kev_date_added":null,"published":"2012-08-28"},{"cvss_score":5.4,"headline":"Missing authorization in n/a","id":"CVE-2015-8688","kev_date_added":null,"published":"2016-01-15"},{"cvss_score":5.3,"headline":"Business logic in n/a","id":"CVE-2022-39835","kev_date_added":null,"published":"2022-09-27"},{"cvss_score":4.3,"headline":"Security feature bypass in n/a","id":"CVE-2012-5524","kev_date_added":null,"published":"2014-02-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Malicious XMPP servers can extract plaintext from OTR encrypted sessions in Gajim due to unconditional implementation of remote control extensions.","url":"https://insights.sbomify.com/CVE-2016-10376/"}