# CVE-2016-10518: Remote Memory Disclosure in ws

> Attackers can cause denial of service in the ws Node.js library by sending ping frames that trigger excessive memory allocation.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** CLSA-2026-1784596272, DEBIAN-CVE-2016-10518, GHSA-2mhh-w6q8-5hxw, MINI-34m9-8mxh-7cxg, MINI-chmh-66jf-4pqx, UBUNTU-CVE-2016-10518

## What is CVE-2016-10518?

CVE-2016-10518 is a high-severity denial of service vulnerability in HackerOne ws node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in the ping functionality of the ws module before 1.0.0 which allowed clients to allocate memory by sending a ping frame. The ping functionality by default responds with a pong frame and the previously given payload of the ping frame. This is exactly what you expect, but internally ws always transforms all data that we need to send to a Buffer instance and that is where the vulnerability existed. ws didn't do any checks for the type of data it was sending. With buffers in node when you allocate it when a number instead of a string it will allocate the amount of bytes.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer), CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2016-10518?

2 open source packages ship an affected version, including ws. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ws` | npm | All versions | 1.0.1 |
| `ws` | npm | All versions | 1.0.1 |

Products: Ws Project Ws.

## How do I fix CVE-2016-10518?

Upgrade ws to 1.0.1 or later.

## Is CVE-2016-10518 being exploited?

There is no known exploitation of CVE-2016-10518 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne ws node module

- [CVE-2026-48779](https://insights.sbomify.com/CVE-2026-48779/): ws: Memory exhaustion DoS from tiny fragments and data chunks (high 7.5)
- [CVE-2016-10542](https://insights.sbomify.com/CVE-2016-10542/): DoS due to excessively large websocket message in ws (high 7.5)
- [CVE-2026-45736](https://insights.sbomify.com/CVE-2026-45736/): ws: Uninitialized memory disclosure (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10518 and fix it if it is affected.

What it is: CVE-2016-10518 is a high-severity denial of service vulnerability in HackerOne ws node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10518 in the wild and no public exploit code.

Affected packages and fixed versions:
- ws (npm): affected all versions; fixed in 1.0.1
- ws (npm): affected all versions; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10518/ (Markdown: https://insights.sbomify.com/CVE-2016-10518/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10518
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10518
- OSV: https://osv.dev/vulnerability/CVE-2016-10518

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10518/
Summaries are generated and may contain mistakes; the official description above is the record.
