{"answers":{"affected":"2 open source packages ship an affected version, including rails_admin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10522 in the wild and no public exploit code.","fix":"Upgrade rails_admin to 1.1.1 or later.","what":"CVE-2016-10522 is a high-severity vulnerability in https://github.com/sferik rails_admin ruby gem, published on 5 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-10522 and fix it if it is affected.\n\nWhat it is: CVE-2016-10522 is a high-severity vulnerability in https://github.com/sferik rails_admin ruby gem, published on 5 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-10522 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rails_admin (RubyGems): affected from 1.0.0; fixed in 1.1.1\n- rails_admin (RubyGems): affected from 1.0.0; fixed in 1.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10522/ (Markdown: https://insights.sbomify.com/CVE-2016-10522/index.md)","id":"CVE-2016-10522","markdown":"https://insights.sbomify.com/CVE-2016-10522/index.md","name":"CVE-2016-10522","record":{"aliases":["GHSA-pxqr-8v54-m2hj","UBUNTU-CVE-2016-10522"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Rails admin gem","requires_auth":"none","summary":"Attackers can perform unauthorized administrative actions via CSRF due to missing token validation in non-GET requests.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"rails_admin","vendor":"rails_admin_project"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"rails_admin ruby gem \u003cv1.1.1 is vulnerable to cross-site request forgery (CSRF) attacks. Non-GET methods were not validating CSRF tokens and, as a result, an attacker could hypothetically gain access to the application administrative endpoints exposed by the gem.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site request forgery in rails_admin","id":"CVE-2016-10522","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"csrf","year":"2016"},"n_packages":2,"n_references":3,"next":{"headline":"Denial of Service in mqtt-packet","id":"CVE-2016-10523"},"packages":[{"ecosystem":"RubyGems","fixed":["1.1.1"],"introduced":["1.0.0"],"last_affected":[],"package":"rails_admin","purl":null,"source":"GHSA-pxqr-8v54-m2hj"},{"ecosystem":"RubyGems","fixed":["1.1.1"],"introduced":["1.0.0"],"last_affected":[],"package":"rails_admin","purl":"pkg:gem/rails_admin","source":"GHSA-pxqr-8v54-m2hj"}],"prev":{"headline":"Regular Expression Denial of Service in jshamcrest","id":"CVE-2016-10521"},"products":["rails_admin ruby gem"],"published":"2018-07-05","related":[{"cvss_score":6.8,"headline":"RailsAdmin Cross-site Scripting vulnerability in the list view","id":"CVE-2024-39308","kev_date_added":null,"published":"2024-07-08"},{"cvss_score":6.1,"headline":"rails_admin ruby gem XSS vulnerability","id":"CVE-2020-36190","kev_date_added":null,"published":"2021-01-12"},{"cvss_score":6.1,"headline":"rails_admin ruby gem XSS","id":"CVE-2017-12098","kev_date_added":null,"published":"2018-01-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["https://github.com/sferik"]},"summary":"Attackers can perform unauthorized administrative actions via CSRF due to missing token validation in non-GET requests.","url":"https://insights.sbomify.com/CVE-2016-10522/"}