# CVE-2016-10522: Cross-site request forgery in rails_admin

> Attackers can perform unauthorized administrative actions via CSRF due to missing token validation in non-GET requests.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jul 2018
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-pxqr-8v54-m2hj, UBUNTU-CVE-2016-10522

## What is CVE-2016-10522?

CVE-2016-10522 is a high-severity vulnerability in https://github.com/sferik rails_admin ruby gem, published on 5 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

rails_admin ruby gem <v1.1.1 is vulnerable to cross-site request forgery (CSRF) attacks. Non-GET methods were not validating CSRF tokens and, as a result, an attacker could hypothetically gain access to the application administrative endpoints exposed by the gem.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2016-10522?

2 open source packages ship an affected version, including rails_admin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rails_admin` | RubyGems | From 1.0.0 | 1.1.1 |
| `rails_admin` | RubyGems | From 1.0.0 | 1.1.1 |

Products: Rails Admin Project Rails Admin.

## How do I fix CVE-2016-10522?

Upgrade rails_admin to 1.1.1 or later.

## Is CVE-2016-10522 being exploited?

There is no known exploitation of CVE-2016-10522 in the wild and no public exploit code.

## Other vulnerabilities in https://github.com/sferik rails_admin ruby gem

- [CVE-2024-39308](https://insights.sbomify.com/CVE-2024-39308/): RailsAdmin Cross-site Scripting vulnerability in the list view (medium 6.8)
- [CVE-2020-36190](https://insights.sbomify.com/CVE-2020-36190/): rails_admin ruby gem XSS vulnerability (medium 6.1)
- [CVE-2017-12098](https://insights.sbomify.com/CVE-2017-12098/): rails_admin ruby gem XSS (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10522 and fix it if it is affected.

What it is: CVE-2016-10522 is a high-severity vulnerability in https://github.com/sferik rails_admin ruby gem, published on 5 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-10522 in the wild and no public exploit code.

Affected packages and fixed versions:
- rails_admin (RubyGems): affected from 1.0.0; fixed in 1.1.1
- rails_admin (RubyGems): affected from 1.0.0; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10522/ (Markdown: https://insights.sbomify.com/CVE-2016-10522/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10522
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10522
- OSV: https://osv.dev/vulnerability/CVE-2016-10522

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10522/
Summaries are generated and may contain mistakes; the official description above is the record.
