CVE-2016-10523 Denial of Service in mqtt-packet
Attackers can crash applications using the MQTT packet parser library by sending specifically crafted packets, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-10523?
CVE-2016-10523 is a high-severity denial of service vulnerability in HackerOne mqtt-packet node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible with very little bandwidth.
Which versions are affected by CVE-2016-10523?
4 open source packages ship an affected version, including mqtt-packet. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mqtt-packet npm | All versions | 3.4.6 |
mqtt-packet npm | All versions | 3.4.6 |
mqtt-packet npm | From 4.0.0 | 4.0.5 |
mqtt-packet npm | From 4.0.0 | 4.0.5 |
Products include Mqtt-Packet Project Mqtt-Packet.
How do I fix CVE-2016-10523?
Upgrade mqtt-packet to a fixed version for your release line: 3.4.6 or 4.0.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2016-10523 being exploited?
There is no known exploitation of CVE-2016-10523 in the wild and no public exploit code.
Other vulnerabilities in HackerOne mqtt-packet node module
Sources
Also known as GHSA-g3r2-65gc-qpqc.