{"answers":{"affected":"4 open source packages ship an affected version, including mqtt-packet. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10523 in the wild and no public exploit code.","fix":"Upgrade mqtt-packet to a fixed version for your release line: 3.4.6 or 4.0.5.","what":"CVE-2016-10523 is a high-severity denial of service vulnerability in HackerOne mqtt-packet node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10523 and fix it if it is affected.\n\nWhat it is: CVE-2016-10523 is a high-severity denial of service vulnerability in HackerOne mqtt-packet node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10523 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mqtt-packet (npm): affected all versions; fixed in 3.4.6\n- mqtt-packet (npm): affected all versions; fixed in 3.4.6\n- mqtt-packet (npm): affected from 4.0.0; fixed in 4.0.5\n- mqtt-packet (npm): affected from 4.0.0; fixed in 4.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10523/ (Markdown: https://insights.sbomify.com/CVE-2016-10523/index.md)","id":"CVE-2016-10523","markdown":"https://insights.sbomify.com/CVE-2016-10523/index.md","name":"CVE-2016-10523","record":{"aliases":["GHSA-g3r2-65gc-qpqc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"MQTT packet parser","requires_auth":"none","summary":"Attackers can crash applications using the MQTT packet parser library by sending specifically crafted packets, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"mqtt-packet","vendor":"mqtt-packet_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"MQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible with very little bandwidth.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in mqtt-packet","id":"CVE-2016-10523","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2016"},"n_packages":4,"n_references":3,"next":{"headline":"Denial of Service and Content Injection in i18n-node-angular","id":"CVE-2016-10524"},"packages":[{"ecosystem":"npm","fixed":["3.4.6"],"introduced":["0"],"last_affected":[],"package":"mqtt-packet","purl":null,"source":"GHSA-g3r2-65gc-qpqc"},{"ecosystem":"npm","fixed":["3.4.6"],"introduced":["0"],"last_affected":[],"package":"mqtt-packet","purl":"pkg:npm/mqtt-packet","source":"GHSA-g3r2-65gc-qpqc"},{"ecosystem":"npm","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"mqtt-packet","purl":null,"source":"GHSA-g3r2-65gc-qpqc"},{"ecosystem":"npm","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"mqtt-packet","purl":"pkg:npm/mqtt-packet","source":"GHSA-g3r2-65gc-qpqc"}],"prev":{"headline":"Cross-site request forgery in rails_admin","id":"CVE-2016-10522"},"products":["mqtt-packet node module"],"published":"2018-05-31","related":[{"cvss_score":7.5,"headline":"Improper Input Validation and Buffer Over-read in mqtt-packet","id":"CVE-2019-5432","kev_date_added":null,"published":"2019-05-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can crash applications using the MQTT packet parser library by sending specifically crafted packets, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2016-10523/"}