# CVE-2016-10523: Denial of Service in mqtt-packet

> Attackers can crash applications using the MQTT packet parser library by sending specifically crafted packets, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-g3r2-65gc-qpqc

## What is CVE-2016-10523?

CVE-2016-10523 is a high-severity denial of service vulnerability in HackerOne mqtt-packet node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible with very little bandwidth.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2016-10523?

4 open source packages ship an affected version, including mqtt-packet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mqtt-packet` | npm | All versions | 3.4.6 |
| `mqtt-packet` | npm | All versions | 3.4.6 |
| `mqtt-packet` | npm | From 4.0.0 | 4.0.5 |
| `mqtt-packet` | npm | From 4.0.0 | 4.0.5 |

Products: Mqtt-Packet Project Mqtt-Packet.

## How do I fix CVE-2016-10523?

Upgrade mqtt-packet to a fixed version for your release line: 3.4.6 or 4.0.5.

## Is CVE-2016-10523 being exploited?

There is no known exploitation of CVE-2016-10523 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne mqtt-packet node module

- [CVE-2019-5432](https://insights.sbomify.com/CVE-2019-5432/): Improper Input Validation and Buffer Over-read in mqtt-packet (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10523 and fix it if it is affected.

What it is: CVE-2016-10523 is a high-severity denial of service vulnerability in HackerOne mqtt-packet node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10523 in the wild and no public exploit code.

Affected packages and fixed versions:
- mqtt-packet (npm): affected all versions; fixed in 3.4.6
- mqtt-packet (npm): affected all versions; fixed in 3.4.6
- mqtt-packet (npm): affected from 4.0.0; fixed in 4.0.5
- mqtt-packet (npm): affected from 4.0.0; fixed in 4.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10523/ (Markdown: https://insights.sbomify.com/CVE-2016-10523/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10523
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10523
- OSV: https://osv.dev/vulnerability/CVE-2016-10523

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10523/
Summaries are generated and may contain mistakes; the official description above is the record.
