{"answers":{"affected":"2 open source packages ship an affected version, including i18n-node-angular. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10524 in the wild and no public exploit code.","fix":"Upgrade i18n-node-angular to 1.4.0 or later.","what":"CVE-2016-10524 is a high-severity denial of service vulnerability in HackerOne i18n-node-angular node module, published on 31 May 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-10524 and fix it if it is affected.\n\nWhat it is: CVE-2016-10524 is a high-severity denial of service vulnerability in HackerOne i18n-node-angular node module, published on 31 May 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-10524 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- i18n-node-angular (npm): affected all versions; fixed in 1.4.0\n- i18n-node-angular (npm): affected all versions; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10524/ (Markdown: https://insights.sbomify.com/CVE-2016-10524/index.md)","id":"CVE-2016-10524","markdown":"https://insights.sbomify.com/CVE-2016-10524/index.md","name":"CVE-2016-10524","record":{"aliases":["GHSA-97gv-3p2c-xw7j"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js i18n module","requires_auth":"low_privilege","summary":"A malicious user can cause Denial of Service or content injection via a development REST API endpoint left enabled in production environments.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"i18n-node-angular","vendor":"i18n-node-angular_project"}],"cvss":{"score":8.2,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"i18n-node-angular is a module used to interact between i18n and angular without using additional resources. A REST API endpoint that is used for development in i18n-node-angular before 1.4.0 was not disabled in production environments a malicious user could fill up the server causing a Denial of Service or content injection.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service and Content Injection in i18n-node-angular","id":"CVE-2016-10524","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2016"},"n_packages":2,"n_references":2,"next":{"headline":"Authentication Bypass in hapi-auth-jwt2","id":"CVE-2016-10525"},"packages":[{"ecosystem":"npm","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"i18n-node-angular","purl":null,"source":"GHSA-97gv-3p2c-xw7j"},{"ecosystem":"npm","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"i18n-node-angular","purl":"pkg:npm/i18n-node-angular","source":"GHSA-97gv-3p2c-xw7j"}],"prev":{"headline":"Denial of Service in mqtt-packet","id":"CVE-2016-10523"},"products":["i18n-node-angular node module"],"published":"2018-05-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"A malicious user can cause Denial of Service or content injection via a development REST API endpoint left enabled in production environments.","url":"https://insights.sbomify.com/CVE-2016-10524/"}