# CVE-2016-10524: Denial of Service and Content Injection in i18n-node-angular

> A malicious user can cause Denial of Service or content injection via a development REST API endpoint left enabled in production environments.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-97gv-3p2c-xw7j

## What is CVE-2016-10524?

CVE-2016-10524 is a high-severity denial of service vulnerability in HackerOne i18n-node-angular node module, published on 31 May 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

i18n-node-angular is a module used to interact between i18n and angular without using additional resources. A REST API endpoint that is used for development in i18n-node-angular before 1.4.0 was not disabled in production environments a malicious user could fill up the server causing a Denial of Service or content injection.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2016-10524?

2 open source packages ship an affected version, including i18n-node-angular. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `i18n-node-angular` | npm | All versions | 1.4.0 |
| `i18n-node-angular` | npm | All versions | 1.4.0 |

Products: I18n-Node-Angular Project I18n-Node-Angular.

## How do I fix CVE-2016-10524?

Upgrade i18n-node-angular to 1.4.0 or later.

## Is CVE-2016-10524 being exploited?

There is no known exploitation of CVE-2016-10524 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10524 and fix it if it is affected.

What it is: CVE-2016-10524 is a high-severity denial of service vulnerability in HackerOne i18n-node-angular node module, published on 31 May 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-10524 in the wild and no public exploit code.

Affected packages and fixed versions:
- i18n-node-angular (npm): affected all versions; fixed in 1.4.0
- i18n-node-angular (npm): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10524/ (Markdown: https://insights.sbomify.com/CVE-2016-10524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10524
- OSV: https://osv.dev/vulnerability/CVE-2016-10524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10524/
Summaries are generated and may contain mistakes; the official description above is the record.
