{"answers":{"affected":"2 open source packages ship an affected version, including hapi-auth-jwt2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10525 in the wild and no public exploit code.","fix":"Upgrade hapi-auth-jwt2 to 5.1.2 or later.","what":"CVE-2016-10525 is a critical authentication bypass vulnerability in HackerOne hapi-auth-jwt2 node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10525 and fix it if it is affected.\n\nWhat it is: CVE-2016-10525 is a critical authentication bypass vulnerability in HackerOne hapi-auth-jwt2 node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10525 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hapi-auth-jwt2 (npm): affected from 5.1.1; fixed in 5.1.2\n- hapi-auth-jwt2 (npm): affected from 5.1.1; fixed in 5.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10525/ (Markdown: https://insights.sbomify.com/CVE-2016-10525/index.md)","id":"CVE-2016-10525","markdown":"https://insights.sbomify.com/CVE-2016-10525/index.md","name":"CVE-2016-10525","record":{"aliases":["GHSA-mg8r-9g6j-hwv9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js JWT auth plugin","requires_auth":"none","summary":"Attackers can bypass authentication in hapi-auth-jwt2 when using the 'try' mode, allowing unauthorized access to protected resources.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"hapi-auth-jwt2","vendor":"dwyl"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"When attempting to allow authentication mode `try` in hapi, hapi-auth-jwt2 version 5.1.1 introduced an issue whereby people could bypass authentication.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authentication Bypass in hapi-auth-jwt2","id":"CVE-2016-10525","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2016"},"n_packages":2,"n_references":3,"next":{"headline":"grunt-gh-pages before 0.10.0 may allow unencrypted GitHub credentials to be written to a log file","id":"CVE-2016-10526"},"packages":[{"ecosystem":"npm","fixed":["5.1.2"],"introduced":["5.1.1"],"last_affected":[],"package":"hapi-auth-jwt2","purl":null,"source":"GHSA-mg8r-9g6j-hwv9"},{"ecosystem":"npm","fixed":["5.1.2"],"introduced":["5.1.1"],"last_affected":[],"package":"hapi-auth-jwt2","purl":"pkg:npm/hapi-auth-jwt2","source":"GHSA-mg8r-9g6j-hwv9"}],"prev":{"headline":"Denial of Service and Content Injection in i18n-node-angular","id":"CVE-2016-10524"},"products":["hapi-auth-jwt2 node module"],"published":"2018-05-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can bypass authentication in hapi-auth-jwt2 when using the 'try' mode, allowing unauthorized access to protected resources.","url":"https://insights.sbomify.com/CVE-2016-10525/"}