# CVE-2016-10526: grunt-gh-pages before 0.10.0 may allow unencrypted GitHub credentials to be written to a log file

> The plugin logs GitHub tokens to the console, potentially exposing credentials to attackers if CI logs are public.

- **Severity:** High 8.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rrj3-qmh8-72pf

## What is CVE-2016-10526?

CVE-2016-10526 is a high-severity vulnerability in HackerOne grunt-gh-pages node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A common setup to deploy to gh-pages on every commit via a CI system is to expose a github token to ENV and to use it directly in the auth part of the url. In module versions < 0.9.1 the auth portion of the url is outputted as part of the grunt tasks logging function. If this output is publicly available then the credentials should be considered compromised.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File), CWE-255, CWE-391 (DEPRECATED: Unchecked Error Condition)

## Which versions are affected by CVE-2016-10526?

2 open source packages ship an affected version, including grunt-gh-pages. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grunt-gh-pages` | npm | All versions | 0.10.0 |
| `grunt-gh-pages` | npm | All versions | 0.10.0 |

Products: Grunt-Gh-Pages Project Grunt-Gh-Pages.

## How do I fix CVE-2016-10526?

Upgrade grunt-gh-pages to 0.10.0 or later.

## Is CVE-2016-10526 being exploited?

There is no known exploitation of CVE-2016-10526 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10526 and fix it if it is affected.

What it is: CVE-2016-10526 is a high-severity vulnerability in HackerOne grunt-gh-pages node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10526 in the wild and no public exploit code.

Affected packages and fixed versions:
- grunt-gh-pages (npm): affected all versions; fixed in 0.10.0
- grunt-gh-pages (npm): affected all versions; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10526/ (Markdown: https://insights.sbomify.com/CVE-2016-10526/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10526
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10526
- OSV: https://osv.dev/vulnerability/CVE-2016-10526

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10526/
Summaries are generated and may contain mistakes; the official description above is the record.
