{"answers":{"affected":"2 open source packages ship an affected version, including riot-compiler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10527 in the wild and no public exploit code.","fix":"Upgrade riot-compiler to 2.3.22 or later.","what":"CVE-2016-10527 is a high-severity denial of service vulnerability in HackerOne riot-compiler node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10527 and fix it if it is affected.\n\nWhat it is: CVE-2016-10527 is a high-severity denial of service vulnerability in HackerOne riot-compiler node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10527 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- riot-compiler (npm): affected all versions; fixed in 2.3.22\n- riot-compiler (npm): affected all versions; fixed in 2.3.22\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10527/ (Markdown: https://insights.sbomify.com/CVE-2016-10527/index.md)","id":"CVE-2016-10527","markdown":"https://insights.sbomify.com/CVE-2016-10527/index.md","name":"CVE-2016-10527","record":{"aliases":["GHSA-pp4v-55vr-9gxh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript compiler library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using riot-compiler by triggering catastrophic backtracking in a regular expression.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"riot-compiler","vendor":"riot.js"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-399","name":null},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"The riot-compiler version version 2.3.21 has an issue in a regex (Catastrophic Backtracking) thats make it unusable under certain conditions.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in riot-compiler","id":"CVE-2016-10527","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2016"},"n_packages":2,"n_references":2,"next":{"headline":"Directory Traversal in restafary","id":"CVE-2016-10528"},"packages":[{"ecosystem":"npm","fixed":["2.3.22"],"introduced":["0"],"last_affected":[],"package":"riot-compiler","purl":null,"source":"GHSA-pp4v-55vr-9gxh"},{"ecosystem":"npm","fixed":["2.3.22"],"introduced":["0"],"last_affected":[],"package":"riot-compiler","purl":"pkg:npm/riot-compiler","source":"GHSA-pp4v-55vr-9gxh"}],"prev":{"headline":"grunt-gh-pages before 0.10.0 may allow unencrypted GitHub credentials to be written to a log file","id":"CVE-2016-10526"},"products":["riot-compiler node module"],"published":"2018-05-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"An attacker can cause a denial of service in applications using riot-compiler by triggering catastrophic backtracking in a regular expression.","url":"https://insights.sbomify.com/CVE-2016-10527/"}