# CVE-2016-10530: Insecure Default Configuration in airbrake

> The Airbrake Node module sends environment variables over HTTP, allowing network attackers to intercept sensitive secrets like API keys.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-856x-cp3q-47vg

## What is CVE-2016-10530?

CVE-2016-10530 is a medium-severity vulnerability in HackerOne airbrake node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The airbrake module 0.3.8 and earlier defaults to sending environment variables over HTTP. Environment variables can often times contain secret keys and other sensitive values. A malicious user could be on the same network as a regular user and intercept all the secret keys the user is sending. This goes against common best practice, which is to use HTTPS.

Weakness: CWE-310, CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-10530?

2 open source packages ship an affected version, including airbrake. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `airbrake` | npm | All versions | 0.4.0 |
| `airbrake` | npm | All versions | 0.4.0 |

Products: Airbrake Airbrake.

## How do I fix CVE-2016-10530?

Upgrade airbrake to 0.4.0 or later.

## Is CVE-2016-10530 being exploited?

There is no known exploitation of CVE-2016-10530 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10530 and fix it if it is affected.

What it is: CVE-2016-10530 is a medium-severity vulnerability in HackerOne airbrake node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10530 in the wild and no public exploit code.

Affected packages and fixed versions:
- airbrake (npm): affected all versions; fixed in 0.4.0
- airbrake (npm): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10530/ (Markdown: https://insights.sbomify.com/CVE-2016-10530/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10530
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10530
- OSV: https://osv.dev/vulnerability/CVE-2016-10530

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10530/
Summaries are generated and may contain mistakes; the official description above is the record.
