{"answers":{"affected":"2 open source packages ship an affected version, including console-io. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10532 in the wild and no public exploit code.","fix":"Upgrade console-io to 2.3.0 or later.","what":"CVE-2016-10532 is a critical authentication bypass vulnerability in HackerOne console-io node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10532 and fix it if it is affected.\n\nWhat it is: CVE-2016-10532 is a critical authentication bypass vulnerability in HackerOne console-io node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10532 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- console-io (npm): affected all versions; fixed in 2.3.0\n- console-io (npm): affected all versions; fixed in 2.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10532/ (Markdown: https://insights.sbomify.com/CVE-2016-10532/index.md)","id":"CVE-2016-10532","markdown":"https://insights.sbomify.com/CVE-2016-10532/index.md","name":"CVE-2016-10532","record":{"aliases":["GHSA-q52j-4q2q-hcj6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js console module","requires_auth":"none","summary":"Attackers can bypass authentication in console-io to execute arbitrary commands via WebSocket, potentially gaining full system access if run as root.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"console-io","vendor":"console-io_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"console-io is a module that allows users to implement a web console in their application. A malicious user could bypass the authentication and execute any command that the user who is running the console-io application 2.2.13 and earlier is able to run. This means that if console-io was running from root, the attacker would have full access to the system. This vulnerability exists because the console-io application does not configure socket.io to require authentication, which allows a malicious user to connect via a websocket to send commands and receive the response.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authentication Bypass in console-io","id":"CVE-2016-10532","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2016"},"n_packages":2,"n_references":1,"next":{"headline":"Private Data Disclosure in express-restify-mongoose","id":"CVE-2016-10533"},"packages":[{"ecosystem":"npm","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"console-io","purl":null,"source":"GHSA-q52j-4q2q-hcj6"},{"ecosystem":"npm","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"console-io","purl":"pkg:npm/console-io","source":"GHSA-q52j-4q2q-hcj6"}],"prev":{"headline":"Sanitization bypass using HTML Entities in marked","id":"CVE-2016-10531"},"products":["console-io node module"],"published":"2018-05-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"Attackers can bypass authentication in console-io to execute arbitrary commands via WebSocket, potentially gaining full system access if run as root.","url":"https://insights.sbomify.com/CVE-2016-10532/"}