# CVE-2016-10532: Authentication Bypass in console-io

> Attackers can bypass authentication in console-io to execute arbitrary commands via WebSocket, potentially gaining full system access if run as root.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-q52j-4q2q-hcj6

## What is CVE-2016-10532?

CVE-2016-10532 is a critical authentication bypass vulnerability in HackerOne console-io node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

console-io is a module that allows users to implement a web console in their application. A malicious user could bypass the authentication and execute any command that the user who is running the console-io application 2.2.13 and earlier is able to run. This means that if console-io was running from root, the attacker would have full access to the system. This vulnerability exists because the console-io application does not configure socket.io to require authentication, which allows a malicious user to connect via a websocket to send commands and receive the response.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2016-10532?

2 open source packages ship an affected version, including console-io. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `console-io` | npm | All versions | 2.3.0 |
| `console-io` | npm | All versions | 2.3.0 |

Products: Console-Io Project Console-Io.

## How do I fix CVE-2016-10532?

Upgrade console-io to 2.3.0 or later.

## Is CVE-2016-10532 being exploited?

There is no known exploitation of CVE-2016-10532 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10532 and fix it if it is affected.

What it is: CVE-2016-10532 is a critical authentication bypass vulnerability in HackerOne console-io node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10532 in the wild and no public exploit code.

Affected packages and fixed versions:
- console-io (npm): affected all versions; fixed in 2.3.0
- console-io (npm): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10532/ (Markdown: https://insights.sbomify.com/CVE-2016-10532/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10532
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10532
- OSV: https://osv.dev/vulnerability/CVE-2016-10532

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10532/
Summaries are generated and may contain mistakes; the official description above is the record.
