CVE-2016-10533 Private Data Disclosure in express-restify-mongoose
Attackers can retrieve private database fields, such as passwords, by exploiting a flaw in the express-restify-mongoose library's distinct query handling.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-10533?
CVE-2016-10533 is a high-severity vulnerability in HackerOne express-restify-mongoose node module, published on 31 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
express-restify-mongoose is a module to easily create a flexible REST interface for mongoose models. express-restify-mongoose 2.4.2 and earlier and 3.0.X through 3.0.1 allows a malicious user to send a request for `GET /User?distinct=password` and get all the passwords for all the users in the database, despite the field being set to private. This can be used for other private data if the malicious user knew what was set as private for specific routes.
Weakness: CWE-200
Which versions are affected by CVE-2016-10533?
4 open source packages ship an affected version, including express-restify-mongoose. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
express-restify-mongoose npm | All versions | 2.5.0 |
express-restify-mongoose npm | All versions | 2.5.0 |
express-restify-mongoose npm | From 3.0.0 | 3.1.0 |
express-restify-mongoose npm | From 3.0.0 | 3.1.0 |
Products include Express-Restify-Mongoose Project Express-Restify-Mongoose.
How do I fix CVE-2016-10533?
Upgrade express-restify-mongoose to a fixed version for your release line: 2.5.0 or 3.1.0.
Is CVE-2016-10533 being exploited?
There is no known exploitation of CVE-2016-10533 in the wild and no public exploit code.
Sources
Also known as GHSA-cgjx-mwpx-47jv.