{"answers":{"affected":"4 open source packages ship an affected version, including express-restify-mongoose. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10533 in the wild and no public exploit code.","fix":"Upgrade express-restify-mongoose to a fixed version for your release line: 2.5.0 or 3.1.0.","what":"CVE-2016-10533 is a high-severity vulnerability in HackerOne express-restify-mongoose node module, published on 31 May 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10533 and fix it if it is affected.\n\nWhat it is: CVE-2016-10533 is a high-severity vulnerability in HackerOne express-restify-mongoose node module, published on 31 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10533 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- express-restify-mongoose (npm): affected all versions; fixed in 2.5.0\n- express-restify-mongoose (npm): affected all versions; fixed in 2.5.0\n- express-restify-mongoose (npm): affected from 3.0.0; fixed in 3.1.0\n- express-restify-mongoose (npm): affected from 3.0.0; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10533/ (Markdown: https://insights.sbomify.com/CVE-2016-10533/index.md)","id":"CVE-2016-10533","markdown":"https://insights.sbomify.com/CVE-2016-10533/index.md","name":"CVE-2016-10533","record":{"aliases":["GHSA-cgjx-mwpx-47jv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js REST library","requires_auth":"low_privilege","summary":"Attackers can retrieve private database fields, such as passwords, by exploiting a flaw in the express-restify-mongoose library's distinct query handling.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"express-restify-mongoose","vendor":"express-restify-mongoose_project"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"express-restify-mongoose is a module to easily create a flexible REST interface for mongoose models. express-restify-mongoose 2.4.2 and earlier and 3.0.X through 3.0.1 allows a malicious user to send a request for `GET /User?distinct=password` and get all the passwords for all the users in the database, despite the field being set to private. This can be used for other private data if the malicious user knew what was set as private for specific routes.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Private Data Disclosure in express-restify-mongoose","id":"CVE-2016-10533","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2016"},"n_packages":4,"n_references":2,"next":{"headline":"SSL Validation Defaults to False in electron-packager","id":"CVE-2016-10534"},"packages":[{"ecosystem":"npm","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"express-restify-mongoose","purl":null,"source":"GHSA-cgjx-mwpx-47jv"},{"ecosystem":"npm","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"express-restify-mongoose","purl":"pkg:npm/express-restify-mongoose","source":"GHSA-cgjx-mwpx-47jv"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["3.0.0"],"last_affected":[],"package":"express-restify-mongoose","purl":null,"source":"GHSA-cgjx-mwpx-47jv"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["3.0.0"],"last_affected":[],"package":"express-restify-mongoose","purl":"pkg:npm/express-restify-mongoose","source":"GHSA-cgjx-mwpx-47jv"}],"prev":{"headline":"Authentication Bypass in console-io","id":"CVE-2016-10532"},"products":["express-restify-mongoose node module"],"published":"2018-05-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can retrieve private database fields, such as passwords, by exploiting a flaw in the express-restify-mongoose library's distinct query handling.","url":"https://insights.sbomify.com/CVE-2016-10533/"}