{"answers":{"affected":"2 open source packages ship an affected version, including electron-packager. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10534 in the wild and no public exploit code.","fix":"Upgrade electron-packager to 7.0.0 or later.","what":"CVE-2016-10534 is a medium-severity vulnerability in HackerOne electron-packager node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10534 and fix it if it is affected.\n\nWhat it is: CVE-2016-10534 is a medium-severity vulnerability in HackerOne electron-packager node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10534 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- electron-packager (npm): affected from 5.2.1; fixed in 7.0.0\n- electron-packager (npm): affected from 5.2.1; fixed in 7.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10534/ (Markdown: https://insights.sbomify.com/CVE-2016-10534/index.md)","id":"CVE-2016-10534","markdown":"https://insights.sbomify.com/CVE-2016-10534/index.md","name":"CVE-2016-10534","record":{"aliases":["GHSA-q43m-ffwr-rpcc"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Electron packaging tool","requires_auth":"none","summary":"The tool defaults to disabling SSL verification, allowing attackers to perform man-in-the-middle attacks during package downloads.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"electron-packager","vendor":"electron-packager_project"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"electron-packager is a command line tool that packages Electron source code into `.app` and `.exe` packages. along with Electron. The `--strict-ssl` command line option in electron-packager \u003e= 5.2.1 \u003c= 6.0.0 || \u003e=6.0.0 \u003c= 6.0.2 defaults to false if not explicitly set to true. This could allow an attacker to perform a man in the middle attack.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SSL Validation Defaults to False in electron-packager","id":"CVE-2016-10534","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2016"},"n_packages":2,"n_references":2,"next":{"headline":"Timing Attack in csrf-lite","id":"CVE-2016-10535"},"packages":[{"ecosystem":"npm","fixed":["7.0.0"],"introduced":["5.2.1"],"last_affected":[],"package":"electron-packager","purl":null,"source":"GHSA-q43m-ffwr-rpcc"},{"ecosystem":"npm","fixed":["7.0.0"],"introduced":["5.2.1"],"last_affected":[],"package":"electron-packager","purl":"pkg:npm/electron-packager","source":"GHSA-q43m-ffwr-rpcc"}],"prev":{"headline":"Private Data Disclosure in express-restify-mongoose","id":"CVE-2016-10533"},"products":["electron-packager node module"],"published":"2018-05-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"The tool defaults to disabling SSL verification, allowing attackers to perform man-in-the-middle attacks during package downloads.","url":"https://insights.sbomify.com/CVE-2016-10534/"}