# CVE-2016-10534: SSL Validation Defaults to False in electron-packager

> The tool defaults to disabling SSL verification, allowing attackers to perform man-in-the-middle attacks during package downloads.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-q43m-ffwr-rpcc

## What is CVE-2016-10534?

CVE-2016-10534 is a medium-severity vulnerability in HackerOne electron-packager node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

electron-packager is a command line tool that packages Electron source code into `.app` and `.exe` packages. along with Electron. The `--strict-ssl` command line option in electron-packager >= 5.2.1 <= 6.0.0 || >=6.0.0 <= 6.0.2 defaults to false if not explicitly set to true. This could allow an attacker to perform a man in the middle attack.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2016-10534?

2 open source packages ship an affected version, including electron-packager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron-packager` | npm | From 5.2.1 | 7.0.0 |
| `electron-packager` | npm | From 5.2.1 | 7.0.0 |

Products: Electron-Packager Project Electron-Packager.

## How do I fix CVE-2016-10534?

Upgrade electron-packager to 7.0.0 or later.

## Is CVE-2016-10534 being exploited?

There is no known exploitation of CVE-2016-10534 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10534 and fix it if it is affected.

What it is: CVE-2016-10534 is a medium-severity vulnerability in HackerOne electron-packager node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10534 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron-packager (npm): affected from 5.2.1; fixed in 7.0.0
- electron-packager (npm): affected from 5.2.1; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10534/ (Markdown: https://insights.sbomify.com/CVE-2016-10534/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10534
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10534
- OSV: https://osv.dev/vulnerability/CVE-2016-10534

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10534/
Summaries are generated and may contain mistakes; the official description above is the record.
