# CVE-2016-10536: Insecure Defaults Allow MITM Over TLS in engine.io-client

> Attackers can bypass TLS certificate validation in engine.io-client due to improper handling of null settings, enabling man-in-the-middle attacks.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-4r4m-hjwj-43p8

## What is CVE-2016-10536?

CVE-2016-10536 is a medium-severity vulnerability in HackerOne engine.io-client node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

engine.io-client is the client for engine.io, the implementation of a transport-based cross-browser/cross-device bi-directional communication layer for Socket.IO. The vulnerability is related to the way that node.js handles the `rejectUnauthorized` setting. If the value is something that evaluates to false, certificate verification will be disabled. This is problematic as engine.io-client 1.6.8 and earlier passes in an object for settings that includes the rejectUnauthorized property, whether it has been set or not. If the value has not been explicitly changed, it will be passed in as `null`, resulting in certificate verification being turned off.

Weakness: CWE-295 (Improper Certificate Validation), CWE-300 (Channel Accessible by Non-Endpoint)

## Which versions are affected by CVE-2016-10536?

2 open source packages ship an affected version, including engine.io-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `engine.io-client` | npm | All versions | 1.6.9 |
| `engine.io-client` | npm | All versions | 1.6.9 |

Products: Socket Engine.io-Client.

## How do I fix CVE-2016-10536?

Upgrade engine.io-client to 1.6.9 or later.

## Is CVE-2016-10536 being exploited?

There is no known exploitation of CVE-2016-10536 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10536 and fix it if it is affected.

What it is: CVE-2016-10536 is a medium-severity vulnerability in HackerOne engine.io-client node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10536 in the wild and no public exploit code.

Affected packages and fixed versions:
- engine.io-client (npm): affected all versions; fixed in 1.6.9
- engine.io-client (npm): affected all versions; fixed in 1.6.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10536/ (Markdown: https://insights.sbomify.com/CVE-2016-10536/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10536
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10536
- OSV: https://osv.dev/vulnerability/CVE-2016-10536

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10536/
Summaries are generated and may contain mistakes; the official description above is the record.
