# CVE-2016-10537: Cross-Site Scripting in backbone

> Cross-site scripting vulnerability in Backbone.js allows attackers to execute arbitrary scripts via unsanitized input in the Model#Escape function.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2016-10537, GHSA-j6p2-cx3w-6jcp

## What is CVE-2016-10537?

CVE-2016-10537 is a medium-severity cross-site scripting vulnerability in HackerOne backbone node module, published on 31 May 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

backbone is a module that adds in structure to a JavaScript heavy application through key-value pairs and custom events connecting to your RESTful API through JSON There exists a potential Cross Site Scripting vulnerability in the `Model#Escape` function of backbone 0.3.3 and earlier, if a user is able to supply input. This is due to the regex that's replacing things to miss the conversion of things such as `<` to `<`.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-10537?

2 open source packages ship an affected version, including backbone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `backbone` | npm | From 0.3.3 | 0.5.0 |
| `backbone` | npm | From 0.3.3 | 0.5.0 |

Products: Backbone Project Backbone.

## How do I fix CVE-2016-10537?

Upgrade backbone to 0.5.0 or later.

## Is CVE-2016-10537 being exploited?

There is no known exploitation of CVE-2016-10537 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10537 and fix it if it is affected.

What it is: CVE-2016-10537 is a medium-severity cross-site scripting vulnerability in HackerOne backbone node module, published on 31 May 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-10537 in the wild and no public exploit code.

Affected packages and fixed versions:
- backbone (npm): affected from 0.3.3; fixed in 0.5.0
- backbone (npm): affected from 0.3.3; fixed in 0.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10537/ (Markdown: https://insights.sbomify.com/CVE-2016-10537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10537
- OSV: https://osv.dev/vulnerability/CVE-2016-10537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10537/
Summaries are generated and may contain mistakes; the official description above is the record.
