# CVE-2016-10538: Arbitrary File Write in cli


- **Severity:** Low 3.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** CLSA-2026-1774225194, CLSA-2026-1774225195, CLSA-2026-1789900487, CVE-2016-1000021, GHSA-6cpc-mj5c-m9rq, UBUNTU-CVE-2016-10538

## What is CVE-2016-10538?

CVE-2016-10538 is a low-severity vulnerability in Debian Debian Linux, published on 31 May 2018. 

### Official description

The package `node-cli` before 1.0.0 insecurely uses the lock_file and log_file. Both of these are temporary, but it allows the starting user to overwrite any file they have access to.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2016-10538?

2 open source packages ship an affected version, including cli. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cli` | npm | All versions | 1.0.0 |
| `cli` | npm | All versions | 1.0.0 |

Products: Cli Project Cli, Debian Debian Linux.

## How do I fix CVE-2016-10538?

Upgrade cli to 1.0.0 or later.

## Is CVE-2016-10538 being exploited?

There is no known exploitation of CVE-2016-10538 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10538 and fix it if it is affected.

What it is: CVE-2016-10538 is a low-severity vulnerability in Debian Debian Linux, published on 31 May 2018. 
Exploitation: There is no known exploitation of CVE-2016-10538 in the wild and no public exploit code.

Affected packages and fixed versions:
- cli (npm): affected all versions; fixed in 1.0.0
- cli (npm): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10538/ (Markdown: https://insights.sbomify.com/CVE-2016-10538/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10538
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10538
- OSV: https://osv.dev/vulnerability/CVE-2016-10538

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10538/
Summaries are generated and may contain mistakes; the official description above is the record.
