{"answers":{"affected":"2 open source packages ship an affected version, including negotiator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10539 in the wild and no public exploit code.","fix":"Upgrade negotiator to 0.6.1 or later.","what":"CVE-2016-10539 is a high-severity denial of service vulnerability in HackerOne negotiator node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10539 and fix it if it is affected.\n\nWhat it is: CVE-2016-10539 is a high-severity denial of service vulnerability in HackerOne negotiator node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10539 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- negotiator (npm): affected all versions; fixed in 0.6.1\n- negotiator (npm): affected all versions; fixed in 0.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10539/ (Markdown: https://insights.sbomify.com/CVE-2016-10539/index.md)","id":"CVE-2016-10539","markdown":"https://insights.sbomify.com/CVE-2016-10539/index.md","name":"CVE-2016-10539","record":{"aliases":["AZL-44826","CLSA-2026-1774830279","CLSA-2026-1784682762","CLSA-2026-1792489812","CVE-2016-1000022","DEBIAN-CVE-2016-10539","GHSA-7mc5-chhp-fmc3","UBUNTU-CVE-2016-10539"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP negotiator","requires_auth":"none","summary":"Attackers can cause denial of service in Node.js applications using the negotiator library by sending specially crafted Accept-Language headers.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"negotiator","vendor":"negotiator_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"negotiator is an HTTP content negotiator for Node.js and is used by many modules and frameworks including Express and Koa. The header for \"Accept-Language\", when parsed by negotiator 0.6.0 and earlier is vulnerable to Regular Expression Denial of Service via a specially crafted string.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in negotiator","id":"CVE-2016-10539","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2016"},"n_packages":2,"n_references":1,"next":{"headline":"Regular Expression Denial of Service in minimatch","id":"CVE-2016-10540"},"packages":[{"ecosystem":"npm","fixed":["0.6.1"],"introduced":["0"],"last_affected":[],"package":"negotiator","purl":null,"source":"GHSA-7mc5-chhp-fmc3"},{"ecosystem":"npm","fixed":["0.6.1"],"introduced":["0"],"last_affected":[],"package":"negotiator","purl":"pkg:npm/negotiator","source":"GHSA-7mc5-chhp-fmc3"}],"prev":{"headline":"Arbitrary File Write in cli","id":"CVE-2016-10538"},"products":["negotiator node module"],"published":"2018-05-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can cause denial of service in Node.js applications using the negotiator library by sending specially crafted Accept-Language headers.","url":"https://insights.sbomify.com/CVE-2016-10539/"}