# CVE-2016-10539: Regular Expression Denial of Service in negotiator

> Attackers can cause denial of service in Node.js applications using the negotiator library by sending specially crafted Accept-Language headers.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** AZL-44826, CLSA-2026-1774830279, CLSA-2026-1784682762, CLSA-2026-1792489812, CVE-2016-1000022, DEBIAN-CVE-2016-10539, GHSA-7mc5-chhp-fmc3, UBUNTU-CVE-2016-10539

## What is CVE-2016-10539?

CVE-2016-10539 is a high-severity denial of service vulnerability in HackerOne negotiator node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

negotiator is an HTTP content negotiator for Node.js and is used by many modules and frameworks including Express and Koa. The header for "Accept-Language", when parsed by negotiator 0.6.0 and earlier is vulnerable to Regular Expression Denial of Service via a specially crafted string.

Weakness: CWE-20 (Improper Input Validation), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2016-10539?

2 open source packages ship an affected version, including negotiator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `negotiator` | npm | All versions | 0.6.1 |
| `negotiator` | npm | All versions | 0.6.1 |

Products: Negotiator Project Negotiator.

## How do I fix CVE-2016-10539?

Upgrade negotiator to 0.6.1 or later.

## Is CVE-2016-10539 being exploited?

There is no known exploitation of CVE-2016-10539 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10539 and fix it if it is affected.

What it is: CVE-2016-10539 is a high-severity denial of service vulnerability in HackerOne negotiator node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10539 in the wild and no public exploit code.

Affected packages and fixed versions:
- negotiator (npm): affected all versions; fixed in 0.6.1
- negotiator (npm): affected all versions; fixed in 0.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10539/ (Markdown: https://insights.sbomify.com/CVE-2016-10539/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10539
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10539
- OSV: https://osv.dev/vulnerability/CVE-2016-10539

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10539/
Summaries are generated and may contain mistakes; the official description above is the record.
