# CVE-2016-10541: Potential Command Injection in shell-quote

> Attackers can execute arbitrary commands via improper escaping of redirection operators in the shell-quote library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** CLSA-2026-1773274563, GHSA-qg8p-v9q4-gh34

## What is CVE-2016-10541?

CVE-2016-10541 is a critical command injection vulnerability in HackerOne shell-quote node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The npm module "shell-quote" 1.6.0 and earlier cannot correctly escape ">" and "<" operator used for redirection in shell. Applications that depend on shell-quote may also be vulnerable. A malicious user could perform code injection.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2016-10541?

2 open source packages ship an affected version, including shell-quote. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shell-quote` | npm | All versions | 1.6.1 |
| `shell-quote` | npm | All versions | 1.6.1 |

Products: Shell-Quote Project Shell-Quote.

## How do I fix CVE-2016-10541?

Upgrade shell-quote to 1.6.1 or later.

## Is CVE-2016-10541 being exploited?

There is no known exploitation of CVE-2016-10541 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne shell-quote node module

- [CVE-2021-42740](https://insights.sbomify.com/CVE-2021-42740/): Improper Neutralization of Special Elements used in a Command in Shell-quote (critical 9.8)
- [CVE-2026-13311](https://insights.sbomify.com/CVE-2026-13311/): shell-quote parse() is quadratic in token count, enabling denial of service (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10541 and fix it if it is affected.

What it is: CVE-2016-10541 is a critical command injection vulnerability in HackerOne shell-quote node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10541 in the wild and no public exploit code.

Affected packages and fixed versions:
- shell-quote (npm): affected all versions; fixed in 1.6.1
- shell-quote (npm): affected all versions; fixed in 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10541/ (Markdown: https://insights.sbomify.com/CVE-2016-10541/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10541
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10541
- OSV: https://osv.dev/vulnerability/CVE-2016-10541

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10541/
Summaries are generated and may contain mistakes; the official description above is the record.
