# CVE-2016-10544: Denial of Service in uws

> Attackers can crash the Node.js process by sending large compressed WebSocket messages, causing resource exhaustion in the uws library.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-hf5h-hh56-3vrg

## What is CVE-2016-10544?

CVE-2016-10544 is a medium-severity denial of service vulnerability in HackerOne uws node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

uws is a WebSocket server library. By sending a 256mb websocket message to a uws server instance with permessage-deflate enabled, there is a possibility used compression will shrink said 256mb down to less than 16mb of websocket payload which passes the length check of 16mb payload. This data will then inflate up to 256mb and crash the node process by exceeding V8's maximum string size. This affects uws >=0.10.0 <=0.10.8.

Weakness: CWE-20 (Improper Input Validation), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2016-10544?

2 open source packages ship an affected version, including uws. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uws` | npm | From 0.10.0 | 0.10.9 |
| `uws` | npm | From 0.10.0 | 0.10.9 |

Products: Uws Project Uws.

## How do I fix CVE-2016-10544?

Upgrade uws to 0.10.9 or later.

## Is CVE-2016-10544 being exploited?

There is no known exploitation of CVE-2016-10544 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10544 and fix it if it is affected.

What it is: CVE-2016-10544 is a medium-severity denial of service vulnerability in HackerOne uws node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10544 in the wild and no public exploit code.

Affected packages and fixed versions:
- uws (npm): affected from 0.10.0; fixed in 0.10.9
- uws (npm): affected from 0.10.0; fixed in 0.10.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10544/ (Markdown: https://insights.sbomify.com/CVE-2016-10544/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10544
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10544
- OSV: https://osv.dev/vulnerability/CVE-2016-10544

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10544/
Summaries are generated and may contain mistakes; the official description above is the record.
