CVE-2016-10546 Arbitrary Code Injection in pouchdb

Critical 9.8 Published Updated

Attackers can execute arbitrary JavaScript and system commands via unsandboxed map/reduce functions in PouchDB temporary views.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-10546?

CVE-2016-10546 is a critical code injection vulnerability in HackerOne pouchdb node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An arbitrary code injection vector was found in PouchDB 6.0.4 and lesser via the map/reduce functions used in PouchDB temporary views and design documents. The code execution engine for this branch is not properly sandboxed and may be used to run arbitrary JavaScript as well as system commands.

Weakness: CWE-94

Which versions are affected by CVE-2016-10546?

2 open source packages ship an affected version, including pouchdb. It affects 1 product.

PackageAffectedFixed in
pouchdb npmAll versions6.0.5
pouchdb npmAll versions6.0.5

Products include Pouchdb Pouchdb.

How do I fix CVE-2016-10546?

Upgrade pouchdb to 6.0.5 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2016-10546 being exploited?

There is no known exploitation of CVE-2016-10546 in the wild and no public exploit code.

Sources

Also known as GHSA-cgqv-x5cx-xvqh.

Is CVE-2016-10546 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free