# CVE-2016-10546: Arbitrary Code Injection in pouchdb

> Attackers can execute arbitrary JavaScript and system commands via unsandboxed map/reduce functions in PouchDB temporary views.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-cgqv-x5cx-xvqh

## What is CVE-2016-10546?

CVE-2016-10546 is a critical code injection vulnerability in HackerOne pouchdb node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An arbitrary code injection vector was found in PouchDB 6.0.4 and lesser via the map/reduce functions used in PouchDB temporary views and design documents. The code execution engine for this branch is not properly sandboxed and may be used to run arbitrary JavaScript as well as system commands.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2016-10546?

2 open source packages ship an affected version, including pouchdb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pouchdb` | npm | All versions | 6.0.5 |
| `pouchdb` | npm | All versions | 6.0.5 |

Products: Pouchdb Pouchdb.

## How do I fix CVE-2016-10546?

Upgrade pouchdb to 6.0.5 or later.

## Is CVE-2016-10546 being exploited?

There is no known exploitation of CVE-2016-10546 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10546 and fix it if it is affected.

What it is: CVE-2016-10546 is a critical code injection vulnerability in HackerOne pouchdb node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10546 in the wild and no public exploit code.

Affected packages and fixed versions:
- pouchdb (npm): affected all versions; fixed in 6.0.5
- pouchdb (npm): affected all versions; fixed in 6.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10546/ (Markdown: https://insights.sbomify.com/CVE-2016-10546/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10546
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10546
- OSV: https://osv.dev/vulnerability/CVE-2016-10546

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10546/
Summaries are generated and may contain mistakes; the official description above is the record.
