CVE-2016-10548 Arbitrary Code Injection in reduce-css-calc

Medium 6.1 Published Updated

Attackers can execute arbitrary code or inject scripts via crafted CSS input in the reduce-css-calc library, affecting both server and client environments.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2016-10548?

CVE-2016-10548 is a medium-severity code injection vulnerability in HackerOne reduce-css-calc node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Arbitrary code execution is possible in reduce-css-calc node module <=1.2.4 through crafted css. This makes cross sites scripting (XSS) possible on the client and arbitrary code injection possible on the server and user input is passed to the `calc` function.

Weakness: CWE-79, CWE-94

Which versions are affected by CVE-2016-10548?

2 open source packages ship an affected version, including reduce-css-calc. It affects 1 product.

PackageAffectedFixed in
reduce-css-calc npmAll versions1.2.5
reduce-css-calc npmAll versions1.2.5

Products include Reduce-Css-Calc Project Reduce-Css-Calc.

How do I fix CVE-2016-10548?

Upgrade reduce-css-calc to 1.2.5 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2016-10548 being exploited?

There is no known exploitation of CVE-2016-10548 in the wild and no public exploit code.

Sources

Also known as GHSA-4662-j96g-mv46.

Is CVE-2016-10548 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free