{"answers":{"affected":"2 open source packages ship an affected version, including reduce-css-calc. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10548 in the wild and no public exploit code.","fix":"Upgrade reduce-css-calc to 1.2.5 or later.","what":"CVE-2016-10548 is a medium-severity code injection vulnerability in HackerOne reduce-css-calc node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-10548 and fix it if it is affected.\n\nWhat it is: CVE-2016-10548 is a medium-severity code injection vulnerability in HackerOne reduce-css-calc node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-10548 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- reduce-css-calc (npm): affected all versions; fixed in 1.2.5\n- reduce-css-calc (npm): affected all versions; fixed in 1.2.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10548/ (Markdown: https://insights.sbomify.com/CVE-2016-10548/index.md)","id":"CVE-2016-10548","markdown":"https://insights.sbomify.com/CVE-2016-10548/index.md","name":"CVE-2016-10548","record":{"aliases":["GHSA-4662-j96g-mv46"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"npm CSS calc library","requires_auth":"none","summary":"Attackers can execute arbitrary code or inject scripts via crafted CSS input in the reduce-css-calc library, affecting both server and client environments.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"reduce-css-calc","vendor":"reduce-css-calc_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Arbitrary code execution is possible in reduce-css-calc node module \u003c=1.2.4 through crafted css. This makes cross sites scripting (XSS) possible on the client and arbitrary code injection possible on the server and user input is passed to the `calc` function.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary Code Injection in reduce-css-calc","id":"CVE-2016-10548","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2016"},"n_packages":2,"n_references":2,"next":{"headline":"Sails before 0.12.7 vulnerable to Broken CORS","id":"CVE-2016-10549"},"packages":[{"ecosystem":"npm","fixed":["1.2.5"],"introduced":["0"],"last_affected":[],"package":"reduce-css-calc","purl":null,"source":"GHSA-4662-j96g-mv46"},{"ecosystem":"npm","fixed":["1.2.5"],"introduced":["0"],"last_affected":[],"package":"reduce-css-calc","purl":"pkg:npm/reduce-css-calc","source":"GHSA-4662-j96g-mv46"}],"prev":{"headline":"Cross-Site Scripting in nunjucks","id":"CVE-2016-10547"},"products":["reduce-css-calc node module"],"published":"2018-05-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"Attackers can execute arbitrary code or inject scripts via crafted CSS input in the reduce-css-calc library, affecting both server and client environments.","url":"https://insights.sbomify.com/CVE-2016-10548/"}