# CVE-2016-10548: Arbitrary Code Injection in reduce-css-calc

> Attackers can execute arbitrary code or inject scripts via crafted CSS input in the reduce-css-calc library, affecting both server and client environments.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-4662-j96g-mv46

## What is CVE-2016-10548?

CVE-2016-10548 is a medium-severity code injection vulnerability in HackerOne reduce-css-calc node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Arbitrary code execution is possible in reduce-css-calc node module <=1.2.4 through crafted css. This makes cross sites scripting (XSS) possible on the client and arbitrary code injection possible on the server and user input is passed to the `calc` function.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2016-10548?

2 open source packages ship an affected version, including reduce-css-calc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `reduce-css-calc` | npm | All versions | 1.2.5 |
| `reduce-css-calc` | npm | All versions | 1.2.5 |

Products: Reduce-Css-Calc Project Reduce-Css-Calc.

## How do I fix CVE-2016-10548?

Upgrade reduce-css-calc to 1.2.5 or later.

## Is CVE-2016-10548 being exploited?

There is no known exploitation of CVE-2016-10548 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10548 and fix it if it is affected.

What it is: CVE-2016-10548 is a medium-severity code injection vulnerability in HackerOne reduce-css-calc node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-10548 in the wild and no public exploit code.

Affected packages and fixed versions:
- reduce-css-calc (npm): affected all versions; fixed in 1.2.5
- reduce-css-calc (npm): affected all versions; fixed in 1.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10548/ (Markdown: https://insights.sbomify.com/CVE-2016-10548/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10548
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10548
- OSV: https://osv.dev/vulnerability/CVE-2016-10548

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10548/
Summaries are generated and may contain mistakes; the official description above is the record.
